Blender 4.1 G, R, and S shortcut keys

Hi! In Blender 4.0 the G,R, and S shortcut keys work as they always have but in Blender 4.1 and 4.1.1 they don't seem to be working. For example, if I select the default cube and type GX2 to move the cubit 2 units along the X axis, I get the popup menu asking me to confirm the delete (i.e it ignores the G key). Same with R and S. When I right click on the toolbar Move icon to get the shortcuts, it says Shortcut: Shift Spacebar, 3 followed by Shortcut Cycle: G. The same for the Rotate and Scale icons except the Shortcut Cycle is R and S respectively. If I Menu select Object > Transform, the Move shortcut says 'drag Left Mouse' and the Rotate and Scale shortcuts are blank. I tried comparing the Blender 4.0 and 4.1 Preferences > keymaps but I'm a beginner and they don't look very similar. Can yo please help me? Thanks!
1 love
  • Omar Domenech replied

    I got freaked out once when I thought they had change those hotkeys. I downloaded a new Blender, tried to G to grab, S to scale, R to rotate, and they weren't working, and I'm like Oh my god! they changed all the hotkeys! This is sacrilegious. Turned out my Keyboard batteries had just died right at that moment. I'm using 4.1 and everything works as always. Try re-downloading Blender 4.1 and updating drivers on your PC, see if any of that helps. 

    1 love
  • Dwayne Savage(dillenbata3) replied

    I'd try file->defaults->load factory settings. See if that fixes it. If not then redownload blender. Uninstall and reinstall blender. 

  • gracelw3d replied

    Thanks for all the help everyone! I did try the file->defaults->load factory settings and that did the trick - thank you! Now to reinstall the addons - lol! But I'm thankful that the G, R, S shortcuts work again and it's probably a good idea to start from a clean slate!

    1 love
  • Martin Bergwerf replied

    ggracelw3d ,

    The most likely places in the Keymap Preferences, that change those main shortcuts are here:


    If this happens again, or if someone else sees this, there is no need to re-install all Addons and so.

    "Load Factory Settings" is great to see if your hardware might be a problem, or if problems arise due to some Setting in your Preferences, or maybe a 3rd party Addon, because it isn't permanent (it doesn't change your Startup File).

    2 loves
  • gracelw3d replied

    Thanks for the additional information Martin! Everyone is so helpful here :)

    1 love