Mirror modifier / Symmetry - Gives unexpected result

Question Modeling

Hello everyone! 

A few weeks ago I have been working on something, where I used the mirror modifier for. 

It all worked as expected, only after I noticed that for just 1 vertex it did not behaved as expected. 

For some reason this one vertex creates a weird shading issue only on one side. If I apply symmetry in edit mode, it just flip-flops it to the other side of the model. (I have off course tried all possible, relevant, symmetry axis without succes). Also, when deleting the "bad part" of the mesh, and re-applying mirror modifier, it is back again.. 

In image 1) You can see the slight shading difference between the right and left side. 

In image 2) I deliberately pulled the vertex down in the z-axis, to emphasise the different results . 

(In the images the edge-crease and bevel-weight are still applied, but when I remove/disable these it still occurs.) 

I was wondering if someone can guide me where I need to look for to solve this. Or am I missing something big here? 

Many thanks in advance! 

Image 1.png

Image 2.png

  • Omar Domenech replied

    But there's no mirror modifier in the stack? You mean this happens after you apply the mirror modifier? You should delete one half of the model and apply the mirror and you should by the laws of physics and programming get the exact same result on each side. If not then we should call that priest we're always about to call.

  • Kiara Bracka replied

    Thanks for your quick reply :) 

    It is indeed not in the stack. (I took the screenshots just incase I was not able to fix it and wanted to revisit this problem, and thus after I applied it). 

    But as mentioned, I tried to fix it by removing the "bad" side, and re-applying the mirror modifier without any succes. Also apply symmetry did not solve this. I have to check, but I might be possible to share a blend file where this is still occurring. 

  • Adrian Bellworthy replied

    Looks like you may have double vertices...
    In edit mode select everything with A, press M and Merge By Distance.
    You may need to increase the default distance a tad.

  • Omar Domenech replied

    You can also upload the file for us to take a look and do some troubleshoot.

  • Martin Bergwerf replied

    Hi Kiara,

    What Blender Version are you using and did you change Version in between?

    Apart from the fact that the Mirror Modifier is always symmetrical, it looks like your UI is missing things:


    This can be caused by opening a file made in 3.x in 4.x...or maybe your (graphics) drivers are not up to date...?

    If you can upload your .blend file, that would be great (preferably with the Mirror Modifier).

  • Kiara Bracka replied

    Hello all, 

    First of all, my apologies for the late reply! 

    I want to share the file but I don't find a way to add it to the post. (sorry I am still new here!)


    In cases like these, I always have my standard list of steps of troubleshooting I go through. And checking for double- and merging vertices is one of them, but this did not solved it either.

    But what I found the weirdest thing with this one, was after I applied the mirror-modifier it still showed this "artefact", so I also applied the symmetrise-option in edit mode. Hoping it would "copy" the good side, to the "bad" side, but instead, the shading artefact just moved to the other side instead. 

    Not knowing it is relevant:  the previous images I have shared, where you can see the vertexes being "pulled" in the z-axis, was done using the "mesh-symmetry" being active in edit mode as well. 

    In the meantime I have found a "work-around" to get rid of the problem, by activating adaptive-subdivision in the subdivision modifier.

    Anyway, once I know how to upload a blend file here, I'll share it straight away!  

    Ps. I was using Blender 4.0 when it first encountered, and it is still there in 4.1

    Image 3.png

  • Omar Domenech replied

    You can't upload the file directly to the forum, you can upload it to DropBox or Google Drive and just paste the link here so we can download it.

  • Martin Bergwerf replied

    Hi Kiara,

    you can upload your .blend to Dropbox, GoogleDrive, or so and post a link here.

    But looking at your screenshot, I think it might not be the Mirror Modifier causing the problem...(I suspect the Solidify, but that's just a guess...)