Mesh Modeling Bootcamp - Modeling a Logo Pt. 1

Question Modeling


I'm posting this in the community instead of the course page, because there I'm not able to upload images.

It seems my question was asked before in the same video page and I did what was instructed there, but I still can't see the wireframe. The first image is from the course and the last two are mine. There are more wireframes in his example and I get a weird result when applying the same thing.

Since this video, Blender has changed a bit and I found some of the settings in Object Properties -> Viewport Display -> All Edges. I think this is the same setting, but I'm not sure.

I also tried Viewport Overlays and under Geometry I checked Wireframe. Under the Subdivision Modifier Optimal Display is on. I think this is everything I did.

Also I want to see the wire while I'm in solid shading view. But I guess that would be the same issue.



  • Martin Bergwerf replied

    Hi Roxana,

    Turn of 'Optimal Display' in the Subsurf Modifier.

    Furthermore, the Overlay Wireframe is for all Objects in the Viewport, while Wireframe in the Object Properties Tab is per Object. So you don't need to set them both.

    1 love
  • Roxana Moise-Dan(ox) replied

    Thanks! Works now.

  • Roxana Moise-Dan(ox) replied


    I'm coming back to this because I still have those extra straight lines when using Subdivision Surface. They are kind of distracting to me, and I didn't find where to hide them. I can see, looking at others, that usually those lines do not exist.  Is there a way to make them disappear?

    Also, I saw that whenever Jonathan enters Object Mode, he is able to toggle off/ on the modifier, whereas I can only do that if I disable it from the Modifiers Properties Panel. Maybe this is something that changed with the newer versions of Blender?


    modifier off

    modifier on


  • Martin Bergwerf replied

    Ooh, you might not be able to get the same representation in modern Blender as in 2.79 or earlier...

    I will look into it tomorrow and get back to you, Roxana.

  • Omar Domenech replied

    JL might be doing the Control + 1 or 2 or 3 as the shortcut to get the subdivision level he desires. And that's why it looks he is turning on or off the modifier.

    As for the lines, do you mean you want to not have the modifier results showed when you enter edit mode? If it's that, you can just toggle the "Display Modifier in Edit Mode button". In the modifier, it's the one next to the screen display icon.

  • Martin Bergwerf replied

    Hi Roxana,

    These are the Settings Jonathan is using in the Course, as far as I can tell.


    Left is in Edit Mode and right is the same in Object Mode.

    To get rid of the straight lines, enable those 2, now grey, icons, like Omar mentioned above.

    It doesn't really get rid of them, but 'bends' them, using the Subdiv.

    You can't see the Subdivided Wireframe and the 'bend' lines at the same time.

  • Roxana Moise-Dan(ox) replied

    Thank you, guys! Yes, it was just like Omar said. And now I have the same result as in the screenshot above. Thanks a bunch!

    • 🤘