William Miller

Rendering Problem

I tried to render an image, but my computer froze whenever I started rendering it, forcing me to restart my computer.  To fix that, I decided to separate my scene into render layers and render them separately.  My computer didn't freeze, but the renders were 100% black.  How can I fix this?

  • Hi William, a link to your .blend would be most helpful...

  • Which version of blender are you using ? In 2.80 you can check if the layer is used for Rendering as below:

    In earlier versions (2.79 and below) you need to make sure each render layer you want to render is checked:

  • tbrbn Good point, but that would give an error: 'All render layers are disabled' and not black renders.

  • spikeyxxx This could have changed with latest build on 2.80 but I experienced the black screen issue with a 2.80 release lately.


  • tbrbn Sounds like it could be a bug, but I tried it on today's 2.80 build (for Linux) and on 2.79b and both just gave the error message.

    The only time I could get black renders was when I disabled all lights...



  • spikeyxxx Yeah I didn't get the issue either on today's build (windows). 

    Actually the missing lights might actually be the problem, it happened more than once to me that I forgot to move the lights to a specific collection and then disable it :D

  • My Blender version is 2.79.  I will link my .blend file.

  • williamatics Hi William, thank you for suplying your .blend file.

    I couldn't test it completely, due to missing textures, but one thing I did find, was that your subsurf modifier was set to 10 in the render. That is enough to crash a NASA computer;) No. but seriously, when I reduced that to 5, it no longer crashed. With a scene like this, you shouldn't need to render separate Layers. Also no more black renders in my testing Try it and let us know if it helped.

  • spikeyxxx Thank you for helping.  It works!  I thought that maybe 10 subdivisions wouldn't be so bad because it was fine when I was in rendered view in the 3D viewport, and because the faces were so large.  I guess not.

  • williamatics Yes, but in rendered view it was only 4 subdivisions. 10 subdivisions is 2 to the power of 6 extra subdivisions, and that is about 64 times the geometry. You could use the Experimental feature in Cycles and use adaptive subdivision, but I think you don't need this in your scene. Anyway, glad I could be of help.

  • spikeyxxx I am sorry, but I wasn't thinking and I just need to correct this: 10 subdivisions is 4 to the power of 6 extra subdivisions, which makes 4096 times the geometry. because a mesh is 2 dimensional (bent in 3D space), so one square, subdivided once, makes four squares ( twice the length and twice the width!) and subdivided twice makes 16 squares and so on.