Alejandro Escobar (alej0)

3 replies · posted

Unknown red lines in beer render


Do you see the top of the liquid? It has some red and white lines, but I don't know why, the radius of the liquid mesh is fine, overlaping the glass.

Here is my blend file: https://mega.nz/#!EGQSmbKA!h0PAkcQNG1EfjRVlMWFD01UibB6UPeVz7Fm4mGyRB1E

  • you say the liquid mesh overlaps the glass mesh, most renderers do not tolerate this well as in having to go through the outside of the glass and then encountering the outside of the liquid and then the inside of the glass and often producing unrealistic results...

    perhaps try eliminating the inside of the glass and leaving the outside of the liquid to represent the change from one material to the next?

    glass and it's reflection and refraction can be very tricky...

    hope this helps... :D

  • What confuses me is that I followed this tutorial, he does the same, and doesn't have a problem: 

    https://www.youtube.com/watch?v=Xbc3KMIOuKM&t=

    About the liquid mesh overlaping the glass, It's from here too:

    http://adaptivesamples.com/2013/10/19/fluid-in-a-glass/

    If their renders are perfect, what am I doing wrong? The normals are correct, I tried rendering with CPU and GPU, If I change the size of the liquid, to leave space between the glass, It doesn't look good...

    Thanks anyway

  • Hola Alejandro,

    Bienvenido a Blender y sus tutores.

    Change the camera angle and those red lines are gone.

    Those red lines appear because of an incorrect match with the beer and the glass. You can spend the rest of your life to get it right. Therefore fake the problem with the camera to change the view of the angle of the light. Tutors don’t talk about stuff they don’t know the answer to.

    Open two viewports. One viewport set to render, the other one to solid and the one you have set to solid, ‘Lock camera to view’ (in the 'n' pannel) in object mode and rotate until those red lines are gone.

    If you have done so you will still have an artifact at the left of your glass. Kind of the same one you have at the front in your image you have posted .)

    Go to edit mode in the viewport, you have set to ‘Solid’, and select a vertex of the beer in the area were the artifact is. With ‘Proportional editing’ enabled, move it slightly towards the left and also that artifact will be gone. You can watch your progress in the viewport you have set to ‘Render’.

    There still is an artifact @ 1 o’clock in my image. Repeat the same process by moving a vertex in that area slightly outwards, along the y-axis with ‘proportional editing’ enabled, and that one will be gone too.

    I am referring to the file you have posted. You will have to open the same file too.