Coins fall through chest

I'm following along with lesson #14, using the released Blender 2.80

When I simulate the coins falling, some of them stop at the bottom of my collider (box), but the majority fall through.  They all have identical physics settings (which I have re-added just to be sure)

Any idea what I might be doing wrong?  I'm happy to share my .blend file if it helps.

  • crew

    I'm happy to share my .blend file if it helps.

    Yes Gary, if you could share your .blend I will take a look. The best way is by uploading to Dropbox, Google Drive, or equivalent hosting service, copying the share link, then pasting here so I can download it.

  • Here you go: https://drive.google.com/open?id=1WeuAQ0dQJmscWesekzXniHW53L2YMPZH

    Note: this was only a rough following of your course - not enough time for all the extensive modeling and texturing, just enough to get the gist of the tools and flow. I'm pretty sure I followed the coin setup carefully though.

    BTW, I love all your courses (and I don't think I've skipped any so far...)

    Thanks for the help

  • Hello Gary and Kent!  I don't know if this is a valid solution ( I'm a blender noob), but I had a similar issue with the very first coin. In my case, it looks like a precision issue with the collision.  Adding a solidify modifier to the chest's rigidbody mesh gave it enough thickness to register the coin hits. 

    If it's anything like Unity collision, the rigid body sometimes passes through the collision object faster than the physics system can detect it.   Making the object thicker gives it a better chance of catching them.


  • That's a good observation & I too have seen this behavior in Unity, so I'm familiar with the issues.

    I tried it with my setup and with a solidify set to about 0,1m, basically, no coins fell through the bottom (a few bounced out, but that's because I had made them very bouncy!)  I tried setting the solidify thinner, but didn't get as good results.  I suppose ideally one could add the solidify modifier and then scale to get it to fit the box as tightly as without.

    Thanks for the idea.

  • crew

    Sorry I'm late getting this file tested - thank you for providing it! The way I solved it was to double the Margin setting to 0.2m, found by selecting your collision box object then looking in the physics settings under "Sensitivity". Essentially this setting is like a thickness for the collision solver; the thicker the walls of your collider are, the less likely objects will slip through.

    You should notice that this will prevent the coins from falling through but it introduces a new problem: The coins hit against an invisible wall leaving a gap in between the coins and the walls of the chest. To solve this simply scale the box larger to negate the gap. Be sure to apply your scale with CTRL + A before simulating again.


  • Finally had a chance tp try this (moving house) - it also worked quite nicely.  Thanks