kjallison

6 answers · asked · Lesson: Array Modifier · Course: Modeling with Modifiers

When i add the Empty my whole array goes crazy

When i add the Empty my whole array goes crazy, my objects are flipping in random directions and they very in sizes. I tried fixing this by adjusting my scale to 1 but then that changes all my dimensions and ruins the object . Not sure what i can do to fix.

  • Hi,  I am not a member of staff but i have had this difficulty as well.  Try doing control A - apply location , scale & possibly rotation if you have scaled, moved the object &/or rotated the object since you created it & before creating array and setting the object offset to your empty.

  • I had to make the empty a child of the stairs else it wouldn't work

  • I am currently using the Blender 2.8 version.

    I had the same issue.  Here is how i solved the problem.

    1-I started with a simple cube, just to keep things simple

    2- Selected the cube, entered in edit mode, selected all elements (vertices+edges) with the A-key and displaced them all at once.

    ( you'll notice while performing the displacement that the origin point remains a the same position, just keep going it is part of the plan)

    3- Got back in object mode, created an "empty",  and made sure the empty was at the SAME position with the origin point of the cube.

    4- Added the "array" modifier to the cube (here was my settings)

    6- In addition to the position, I made sure the empty and the cube had the same SCALE (it made the difference for me).

    7- I selected the empty and performed a rotation with respect to the z-axis.


    I hope my answer will help you. Good luck!

  • is there any way to do this without entering edit mode ?