Avery Musbach (digital-emotions)

1 answer · asked · Lesson: Bake a Hard Surface Normal Map · Course: Normal Map Modeling for Games

some baked normals appear flipped on Sketchfab

See the issues I have circled in red below:

Trying to track down the problem, I have started from the provided blend file and done only the bare minimum required to get the bake going. The visual artifacts above do not appear in Blender, but they show up when I export to FBX and then upload to Sketchfab. I do not see a problem on the normal map:

The above Sketchfab screenshots are all with the Flip green (-Y) checkbox unchecked, and if I check that box then some areas look good, but there are still issues:

I have been experimenting with a few ideas but I cannot solve the problem. Should the Flip green (-Y) checkbox be checked or not, and what is going on?

  • crew

    Hey digital-emotions , that is odd! I'd check these things first: 

    Are there multiple UV maps listed in the object data tab? If so, delete the ones you don't need any longer. What gets rendered in Blender isn't always what gets exported if there are multiple, which can cause some confusion. 

    Second, are the normals of those parts flipped on the mesh itself? That would cause the normals to be backwards since the whole thing will be interpreted in the negative.