polygondust

5 replies · posted

[SOLVED] Individual feathers to parts of armature [Piero tutorial]

Hello!


I got to the mesh skinning portion of the piero tutorial. Is there an obvious step I'm missing with the feathers? Only the most recent one that I parented to the armature will deform.

The steps I'm following, as in the tutorial, are : select all bones, deform to off. Select desired bones, deform to on. Parent the current feather to the whole armature. Repeat for next feather.

Note below, how the two inner feathers won't move at all. However, they are set up the same way as the one that is moving.

Blend file link (no tex)


Could someone let me know if they find a solution? Thanks for reading!

theluthier frikkr jlampel 

  • crew

    After looking through your .blend file, I can see a couple issues:

    1. All flight feathers aside from you deforming one don't appear that they've been parented to the armature. When they're parented, all bones with "deform" enabled will appear as vertex groups on the feather mesh. Currently our flight feathers do not have those vertex groups except for the deforming one.
    2. Only the feather bones that are currently moving that one deforming feather mesh have "deform" enabled. They'll need to have "deform" re-enabled in order to move their corresponding feather meshes.
    Go back to this lesson and re-watch the process starting at 7:04. If you follow those steps it should work for you. Right now the .blend file looks like you stopped after parenting one feather mesh and bone together.
    • Kent, I'll take a look at it and try those suggestions. Thank you for the help!

    • Ok, the fix was actually pretty simple. You were right about the deform, I just had to re enable it for all bones before manipulating the mesh.

      Most of the feathers I hadn't gotten around to - just the three closest to the body!

      They are working now, though the tertiary (top) feather layer isn't moving along. I suspect it has something to do with these vertex groups only including the primary and secondary layer. Thanks for the troubleshooting!


    • Nevermind, changing the vertex groups did nothing. I ended up making a vertex group for the tertiaries. I must not have assigned them correctly, because the tertiaries still refuse to move with the mesh.

      Does this look like a problem you have seen? theluthier

      New Blend File


  • crew

    Glad to see you solved it! Thanks for sharing your solution.