Yves Perera (shinsaku)

6 answers · asked · Lesson: Introducing Blender's Interface · Course: Learn the Blender Basics Tutorial Series

About the update of the course

Hi, nice update (although the previous course was as great as this one). 

I'm kind of surprised though. When I saw that you had updated this, I thought you would be adapting to version 2.8 (even though it's still very early). 

So this makes me wonder... If you go through all the trouble of updating this course, you will want to keep it up for a good amount of time... But with Blender 2.8 coming in a couple of months, you'll have to re-update this whole thing once again. Or does that mean that you are not planning on updating for 2.8?

  • author

    We're planning on updating this course with all new 2.8 content the day that Blender 2.8 comes out so that everyone can keep learning with ease!

  • Hi, I am just starting with Blender and for me it makes zero sense to learn anything < 2.80: the courses available should already be made for Blender 2.80 - in particular if they are targeted at beginners like me - since it is 100% guaranteed that by the time I will be good at it 2.80 will have been delivered. My 2 cents, chris73it

    • I understand your point of view but I also understand the need to wait untill the stable version comes out. When 2.8 became beta, we were told that that meant: polishing the existing tools and no more adding tools. Just making the soft stable for it's release.
      Yet, since then, there has been several major changes like keybord shortcuts changes, new tools added, UI modifications...
      All those things are really annoying for any tutorial maker because any tutorial made before one of those changes makes the video obsolete. Therefore it's safer to wait untill the stable release comes out. Moreover, lots of people are still using 2.79. 


      As much as I'm looking forward to seeing 2.8 tutorials I understand the choice of waiting for the official release. 

    • I'm in a similar boat, except that I'm half-familiar with 2.79, and I've installed 2.8 early. I'm mostly here for a refresher, so 2.8 courses would have been great. However, I totally understand why they'd wait. It takes a lot of time and resources to make one of these videos, and 2.8 is still changing. So by the time they finished re-recording their tutorials for 2.8, version 2.8 might have changed significantly, and they would have to re-re-record all of them -- just to update the screenshots.

      I found that the following video series calls out the major differences really clearly:
      https://www.youtube.com/watch?v=lPVpg4_POww

      It's not ideal, but you might find it helpful to bridge the gap, if you are impatient for 2.8 (like me). ;)

    • I see what you mean and I understand your impatience (who wouln't be impatient with all the hype that 2.8 brings? :p ). 

      Thanks for the link, I've seen it already ^^' 

      What I would suggest you to do, is to go and follow Kents livestreams on this site. Even if you are like me and can't be free during the "live", you can watch the recordings later during your free time (you can find them here: https://cgcookie.com/events?sort_status=archived ). Kent has been using 2.8 in his lives for quite some time now and it helps a lot to get familiar with the new interface. 

      Good luck switching to 2.8 and haapy blending.  :)