Aunnop Kattiyanet (aunpyz)

4 replies · posted

How to setup emissive map in unity

I have a problem with displaying emissive map in unity (but same goes with sketchfab), the texture doens't fade like I expected

Here's what I get

And here's the result I expect from substance painter.

2 images below might help you understand more about my problem, they both showing emissive channel.

  • crew

    If you post the textures I can possibly see what the issue is. This looks like a blend mode issue, although I've had trouble with it in the past myself and I can't quite remember how I resolved it. 

  • crew

    I tested this out myself with Substance Painter and Unity 2017.3 and I didn't seem to have any issues. Here is what I have: 

    I used the "mold" brush in Substance Painter and used only the emission and color for that layer. I believe you did something similar. The base layer is a concrete texture. I didn't change anything within Unity, it just worked with the default values. I would recommend updating to the latest version of Unity if you have not yet. You could also play around with some of the compression settings for the emission texture. 

  • Solved! The problem is I used emissive texture with an alpha, not a black background.

    I didn't export via Unity preset to merge multiple texturesets into 1 texture map, so that's why I get this result.

    Thanks for the reply, though jgonzalez !

  • crew

    Ah ok. I used the Unity preset in Substance Painter but it spits out separate texture maps based on the texture type. So the emission map it gave me had a black background, along with 3 other maps for Albedo, Normal, and Metallic.