polygondust

10 replies · posted

Blender viewport update lag

Hi!

Working through the Piero course still. I'm having a strange problem. I followed the steps in Kent's tutorial perfectly, but I'm getting strange behavior with the bezier that is supposed to move the wing spline.

The settings are exactly the same as tutorial episode 23.

However, Blender isn't updating the screen very well. If I move the bones in edit mode, nothing happens at first.

If I tab back to object mode, it shows how the bezier curve has changed.

There are no problems when I use the empties to move the spline. They update in real time.

This makes me worry there will be problems later getting the splines to update, beyond just screen update problems.

In fact, I couldn't even get the bones to update the curve at all until I followed a weird process. Move the bone, tab into object mode then back into edit mode. Put the bone back. Make sure that on the hook modifier, "view modifier in edit mode" is turned on (off by default). Then when I grab the bone, at first nothing happens:

Hovering mouse:

I have to actually click for it to show how the spline changed, and this only seems to work sometimes.

Never seen Blender behave in such a bizarre way!

Does this problem look familiar to anyone? A bit confused as to what is happening. Maybe a bug that wasn't in the older blender Kent used to make this tutorial. I'll tag some people familiar with the tutorial. Thanks for reading!

theluthier frikkr 

  • I had similar issues with this, and my finished Piero rig still has them. When I pose the wing and tap in and out of modes, it does weird stuff. I believe it is something to do with "dependency graphs" and I think Kent mentions that he finds a workaround for it later on , although this is perhaps in the animation section of the course which I have not done yet.  I also seem to remember that if you open up Kent's version of Piero , it has the same issues. Unless theluthier  says otherwise, I would recommend that you do not dwell on it and just move on. Sorry to be vague but it has been two years since I did the course myself so its hard to remember, but I definitely had similar issues and I think Kent did too and I just left them and kept going :) 

    • Ok, that's actually very helpful, thanks! It was more of an annoyance than a show stopper, though it took me a little bit to figure out how to get it to actually update. Good to know it's just a Blender error, and not an issue with my setup.

  • Looks like this has been a problem since 2013. It's weird, though... I'm having all these issues with drivers not updating with my newer version of Blender, and Kent's tutorial from several years back doesn't seem to have these issues. For instance, I moved on to the next part of the tutorial with toe rigging. In Kent's video, it shows how the drivers effect it in real time. (Video 26 leg rigging, time 18:30). But for me, I have to click before I see how the driver fixes the toes. Same issue as above. I wonder if this problem never got fixed, and actually got worse with newer versions of Blender.

    It wouldn't be such as issue, but I keep thinking I have an error and trying to troubleshoot it... until I realize the drivers just aren't painting their changes to the screen in realtime. Even after clicking update dependencies.

    Someone's error report from 2013:

    https://developer.blender.org/T37431


    theluthier frikkr 

  • crew

    The dependency graph was updated a while ago though. I figured this error would be a thing of the past.

    Can you attach your .blend file for me to take a look polygondust ?

    • Sure! 

      https://drive.google.com/open?id=1fUGCnlihMh8JjRbOPiI7MYv5AEbKcDQO

      Jon's fix helped with the issue somewhat. When I use the new dependency graph as he suggested, I only have to click once to get the wing spline to settle in at the new position. Without the new dependency graph, I grab the wing, click to reposition it, no change. I have to grab it again and then right click out to get it to settle. (I use Blender 2.78, but I tried it on 2.79 fresh download too, same behavior.)

      Either way, it won't update live, even with the new dependency graph turned on. Feel free to look at the Blend file still, but I think this is as good as I can get it. I've moved on to rigging the tail, which won't bend smoothly with the new Bendy Bones options, but I can probably find a workaround.

    • Ah, actually, it might be my graphics card or something... are there settings I can tweak to change how the Blender viewport is rendered?

      It happened to me with the eyes, no splines involved. Just a simple parenting of the mesh to the bones. And I still have to click to get it to set. Weird.

      Hover

      Click


      theluthier 

  • crew

    The dependancy graph was updated a while ago... but it's still not default yet. It'll be finished for 2.8, but for now the way to test the new version is by starting Blender via the command line and adding `--enable-new-depsgraph`at the end. I'm not sure if it'll solve the pierro issue, but it could be worth a shot!

    • Gotcha, thanks for the info! I tried that fix and it made the issue a bit more tolerable. Before, I had to click to set the wing, then grab again and cancel to get the spline to settle correctly. Now I just have to click once which is much less annoying. Not perfect - still won't update in realtime - but much better.

      I read in one of the bug reports that because of how the dependencies work, it might not be able to update until the thing it depends on (the location) has been settled with a click. So it's possible there's no fix for this particular problem.


  • crew

    polygondust After downloading your file, it seems to be have normally to me, at least on my machine. Where the wing control doesn't affect the arm spline until I complete the transformation. However if I press ALT + A to play through the timeline and then move your wing control. That enables me to move the control and have it affect the spline in realtime.

    • theluthier You're right, that workaround allows me to see all the drivers update in realtime! Thank you so much, I didn't think I was going to be able to find a fix. It helps a lot to be able to see how the spline changes in real time, without needing to complete the transform. Thanks for the help, Kent. :)