wyattw

2 answers · asked · Lesson: Stomp Walk Cycle - Intro · Course: Blender Animation Bootcamp

I am keying poses for a walk cycle. Sometimes when I key a pose, go forward a frame, and then return to the keyed frame, ...

I am keying poses for a walk cycle. Sometimes when I key a pose, go forward a frame, and then return to the keyed frame, the key is now in a different position than I keyed it. It seems to be relaxing every time I key it, whether I key its specific set, or i key using automatic key framing, or I paste the frame. Every time it is relaxing the key when I return to it. It is changing the key, so for example, if I set an extreme change on the key, the pose is now extremely modified, but the transform properties will relax if I change the frame I am on in the timeline, and then return. The pose doesn't relax 100%, but it does relax enough to significantly change the pose. pls help
  • crew
    This is a tricky one to solve w/o seeing what you mean. But I would look to see if you have any keys on the root bone, check if a channel is muted by accident or check you're not keying a property like FK/IK if you didn't mean to.
  • I figured out what was causing the issue, although not the exact mechanism behind it. I was using your tutorial as a reference for walk cycles, but not your specific rig. The rig I was using was based upon rigify, but it was heavily modified. many of the control bones had bone constraints added to limit movement to try to prevent the rig from breaking the model, and they were causing the odd behavior of the keyframes changing after keying. I am hypothesizing that this is because of the order of operations, and that the constraints were being applied after the action of keying. I am not sure if this is the specific cause, and I don't know how to test it, but the issue is gone without the bone constraints, so my solution is to remove the constraints, and just be careful when keying to not break the model. This issue is specific to the rig, so, sorry about not specifying that I was using a different model, I just got extremely frustrated after spending hours trying to determine the cause of the odd behavior.