ronald-castle

6 answers · asked · Lesson: Weight Painting · Course: Introduction to Character Modeling

When I parent the rig to the sweater and add automatic weights to it parts of the sweater disappears, why is this and is t...

When I parent the rig to the sweater and add automatic weights to it parts of the sweater disappears, why is this and is there a solution?
  • crew
    This is likely because parts of the sweater are weighted to multiple bones. If those bones are then posed it'll affect the surface in unexpected ways. I'd suggest through each bone in Weight Paint mode and ensure that parts of the mesh are incorrectly applied.
  • I am not seeing anything out of place. When I select the shirt then the rig most of shirt "Seems" to vanish. When I turn of the armature in the modifier panel of the shirt it all comes back. And in paint mode the little bit of shirt that is showing is all blue. When I try to use the ADD brush what ever I paint on goes away. It does the same thing with the pants.
  • crew
    Sorry about the late reply, but this is most definitely a parenting issue with the weights. Unfortunately the only good way to determine the issue is to go bone by bone, checking the assigned verts. One good way to do this is to do it in Edit Mode on the mesh, by cycling through the vertex groups, pressing Select on each group, one by one.
  • Hello, I got the same problem and in my case it was fairly simple to solve : when parenting I had a (discreet) warning message in the top bar stating that "autorun is disabled". So I undo the parenting, I went to user preferences -> files and I checked "autorun python scripts". Then I did once again the parenting and it worked like a charm. Hope this help !
  • You are amazing! I'm sure you just saved me a lot of work.
  • Hey the autorun issue worked for me too, thanks!