jesse94

12 replies · posted

Blender 2.80 full release is not opening on my IMac

Blender 2.80 full release is not opening on my mac am running an iMac osx late 2012 version 10.9.5 Macintosh HD with a 2.9 GHz Intel Core i5 Processor and 8 GB 1600 MHz DDR3 of Memory and an NVIDIA Geforce GTX Graphics card I tried restarting my mac and I also tried re-downloading blender 2.80 here is what it says when I try to open blender in the terminal

  • On the Blender website it says 2.80 needs macOS 10.12+

    But I know nothing about mac, so...

    • spikeyxxx thanks I missed that info on there webside


    • jjesse94 You might consider installing an 'easy' Linux distro alongside your macOS...(dual boot or in a virtual machine)

      It looks to me that your hardware should be able to run 2.80.

    • spikeyxxx I have been doing a little research on virtual machines like VirtualBox and that got me wounding if I can run windows 10 on my mac using VirtualBox and run blender 2.80 on windows 10 and what do the extension pack do for you if you download it alongside the VirtualBox software?


    • jjesse94 You certainly can do that. VirtualBox is a great choice. The extension pack makes it possible to use your mouse and keyboard and other USB devices inside your virtual machine( your Windows 10 or Linux or whatever you want to use to run Blender in), so you will need that!

      Make sure to give the virtual machine enough GB, but if you only use the windows 10 to run Blender, 16GB should be enough.

      I haven't used VirtualBox in a while, so I don't remember everything, but it works fine and it has good documentation.

      You will also easily be able to find tutorials on how to install and use it.

      Good luck!

    • jjesse94 I found that you will need an older version of VirtualBox (4.3.14) for your OS to be supported.

      And also you will need to install the Guest Additions for Windows10 (in your virtual machine).

    • spikeyxxx I instilled windows 10 on my mac and downloaded blender but blender still won't open it well pop up a message saying A graphics card and driver with support for OpenGL 3.3 or higher is required. Installing the latest driver for your graphics card may resolve this issue. How do I instill the latest diver for my graphics card?

         

    • jjesse94 I had a 2011 Macbook Pro and was able to run blender (I had OSX High Sierra installed). I would work 'okay' but perhaps I had a semi-compatible graphics card which may explain how I got blender 2.8 running? 


      I had been using the 2.8 beta since January time frame on that macbook pro as well. I'm scratching my head why it is not working for you though.


      There is a lot of drama on the web about Apple's drop in support for OpenGL in the recent years (enough to confuse me a lot). That may be relevant or may not be.

    • blanchsb  do you thank the problem will be fixed if I upgrade my iMac to the latest version?  

    • jjesse94 I am sorry, I have tried it myself and installed windows 10 on my pc and had the same problem.

      After some research I found out that this is because VirtualBox uses it's own virtual graphics card for the virtual machine.

      Apparently you can get VB to use your graphics card in stead, but I couldn't get that to work....Spend all day trying;)

      Possibly this only works if you have more than one GPU, so you can assign one to VB.

      If you can't get it to work, you might consider dual booting using Apple's Boot Camp...

    • jjesse94 I know that High Sierra is not the current version of Mac OSX (it is now Mojave) and I am not familiar with Mojave because my Macbook is too old to run it. It was working for me on High Sierra though. Just be forwarned blender 2.8 crashes a lot more on Mac than on Windows in my personal experience. I recently purchased a windows laptop because my Macbook is dying a slow and painful death, but I have used blender a lot on my macbook up until this point. The only big major problems I had with it was using complex Eevee nodes in the shader/node editor.

    • spikeyxxx I got blender 2.80 to work I was afraid that all of my other apps will not be supported if I upgraded my iMac but in the end I gave in and upgraded my iMac and it seems like all of my other apps work fine and now I can run blender now