Wayne Dixon (waylow)

255 replies · posted

2.8 Hurdles and Roadblocks

Hey everyone,

With the upcoming release of Blender 2.8 (approx 6 weeks according to Blender.Today) we are trying to put together a list of useful trouble shooting tips for new users to 2.8 and we could use your help.

Have you already been using 2.8 and found yourself scratching your head or trying to figure out a seemly simple thing but it took you HOURS to solve?

Wouldn't it be nice if you helped someone avoid the same trap you fell into.

What kind of stuff are we talking about?

Well not the "Hey where has this button has moved" type of stuff, we're already all over that. 

We're talking more like "My collection is hidden and greyed out but the eyeball icon says it visible - what's going on!?"

Turns out that you have the collection "disabled" in the viewport, but that toggle isn't visible in the outliner because that filter is not enabled.

Or "Weight paint mode no longer has the coloured weights visible when painting."

This is now an 'overlay' feature and when you opened your old 2.7 file that setting just happens to be disabled. (but in a new file it is enabled)

What have you noticed?

We have noticed a few weird behaviors can happen when you open old files.

If you have a tip, or have stumbled over a weird problem that should have been easy to solve, especially when opening your old files, then let us know!

We'd like to be able to help others and stop them from beating their head against a brick wall.

  • Great initiative! I have noticed a strange behavior when unwrapping, the UV projection is dependent of the object's location. It seems to be a bug that hasn't been fixed (yet). As long as the object is located on (0,0,0) or that the location is applied the UV projection "makes sense" but as soon as you move it all hell breaks loose:

    not very convenient ...

    • crew

      tbrbn You found a bug!

      Has this been reported?

      I can do it if you like.  I've reported about 6 last week and most of them have been fixed now.

    • waylow I tweeted about it, that's as far as it went from what I know :D I will check wit today's build if it has been fixed otherwise I'll report it.

      You can report it as well, the more people report bugs the most likely they get fixed :)

      [EDIT] still not working with today's build, reported it here.

  • I haven't used 2.8 yet and I'm afraid to use it.

    • dostovel Take a deep breath and dive in. Took me a few days to get used to it but now I feel more confident with it. Still have a lot of stuff to explore though. It's super stable and most of the add-on are now transferred to 2.8. 

      But admittedly 2.79b was for a while the most advanced and stable version of Blender I've ever seen., I had hard time being convinced 2.80 would top that, but now:

    • tbrbn Be careful Thibaut, know that if you help me, it might turn out you've been dead this whole time.

    • crew

      dostovel It's safe to start learning now Omar.  It's really difficult at first because it really slows you down (super frustrating when you're a pro like yourself). But you can do it!

      I have to agree with Thibaut though.

      2.8 doesn't yet surpass 2.79 in many areas (in its current form), but it easy to see that it will.

      This has been a much bigger change than the 2.49 to 2.5.

    • waylow "when you're a pro like yourself"........ "when... pro.... like yourself"...... " pro....".... "yourself"... "yourself" .................... [throws back against the chair, stops the music, looks at the ceiling, hears the birds chirping, takes a deep breath, opens a bag of Doritos, walks out, stares at the sunset, feels the breeze, sees a cat jump a large gap, he made it, smiles, walks back in]. 

  • Thing 2.79 didn't have but 2.8 have by default and that I find slightly irritating:

    > Auto perspective is set to On by default on Preferences > Viewport. Which means that everytime you toggle between front/rear/side view and another one, it changes the view from orthographic to perspective (and vice versa). I recommend turning it off, it's better for my nerves at least.

    > The Undo function is still random (but I assume it's more a bug than a feature :) )and you have to pray all the CG gods everytime you undo. Avoid frantic Ctrl-Z is what I figured is the safest  way to go at the moment.

    > If you have transparent materials in Eevee they can appear black or mess with the backface culling setup. So you need to change the Blend Mode to Alpha Blend (or whichever result suits you the most) and check or uncheck backface culling.

    (this is obvioulsy not a rant, the overall experience with 2.80 is still very good)

    to be continued...

  • For the next week or two, I will be trying to shine light on the shock that will be finally making the transition from

    Blender 2.79

    to Blender 2.80

    I will log the details of my transition here on this forum thread as I try to convert this scene I made in 2.79 into 2.80

    It will be painful, it will be hard, confusing, bewildering, perplexing. It might be one small digit for blender, but it's one giant leap for my kind.

  • Captains log. Delta Zero Niner, GTM. Three hours with this god forsaken toaster or blender and I'm beginning to go crazy.

    Sorry for the large summary log but it's only because it's the first time. Logs are bound to get shorter.

    [Sees PS4 on desk]. Let me try and model that pretty quick and see...

    - Mildly annoying how I can't tell I'm in Face Select Mode without the little dot in the middle of the face.

    - I can't select/deselect all with "A", very hard to get used to.

    - I can't enter wireframe with "Z", really?

    - A and Z were second nature to me, why Ton!? Why!?

    - I don't like 1, 2, 3 for selection type, give me back CTRL Tab.

    - Pie menus everywhere! CTRL Tab is pie, Period to use cursor as pivot, pie again! Z to enter wireframe pie! pie! pie! Jeez!

    - Uuuuhhh I like how fast using this Pie thing is. It's Pie, swipe and Done. Very nice, I likes.

    - I used to Right Click all the time to get out of, or cancel, modes or menus, now right click always pops up a menu of its own. The most irritating thing so far. I keep right clicking to cancel and the menu keeps popping up and nothing gets canceled.

     - "W" --> remove doubles, now always goes into Circle Select Mode? and now if I right click to get out of circle select mode it just opens up the dangs menu again.

    - Oh my god circle select is annoying. I can now move in the 3D view with it, I can't use the scroll wheel to change sizes and right click to get out of circle select only brings that freaking menu!

    - How do I place the 3D cursor? Right click brings the menu from hell. 

    - How do I cancel things now? Modes seems to linger and not go away like before.

    - Ooooooh W Key alternates between selection modes, very nice. That was not Circle select. Wait.... there are two circle select now? one in W key and one in C key?

    - I don't have to "B" box select every time now. I can move freely and select stuff. Very nice, I likes.  

    - Always always the first thing I did was to CTRL Space bar to get rid of the gizmo, now it maximizes the window. Gizmo still there.

    - Uuuuhh where's Eevee, where's Eevee, where's Eevee?

    - I like how I can select Loop Cut Icon from the Tool Bar and move around in the Viewport and still be in Loop Cut mode and be cutting away, like a Samurai. In 2.79 modes locked the 3D viewport.  

    - But I can't leave Loop Cut Tool by right Clicking! dang menu. How do I get out of tools now?

    - Trying to delete a floating vertex but cant select it, turned out to be something on my monitor screen. 

    - Ok I think I understand, tools stay On now if I select them. Before you summoned them with a hotkey, used them and they went away on their own, that's not the case now. You can select tools at the tool bar as icons and they stay with you until you select something else. That's why right click didn't dismiss them.

    - Everything much more smooth now, even the edge slide feels like butter.

    - Love how I can see tool on the left side and hide it if I want. 

    - Hey I can't put Blender on full screen mode now, what's up with that?

    - Jeez guys you kinda have to be Robin Hood to use the pie menus, you have to be very fast and very precise, otherwise the menu will get stuck and linger

    - Everything looks much more pretty now. 2.79 we have to talk... it's not you, it's me. 

    - Love the workspaces at the top, rapidly sets the UI to every need. 

    - Still don't know how to get rid of the gizmo.  

    - Desktop Icon Blender Logo is the same, why not do a re-branding. A more elegant logo for a more civilized age.

    - That black menu on the lower left keeps popping up, like that Pokemon that comes out of the ground and only shows his face. It's making me look every time. 

    - Ok I get it now, there is no getting rid of the gizmo, it now lives as part of the "literal" Transforms Tools when you select the icon in the left side tools. When I have a selection tool active, it's the old behavior without gizmos.... very nice, I likes. 

    - Most Hotkeys stayed the same.

    - Couldn't figure out how to place the 3D Cursor wherever I wanted it. It used to be right click and it moved there. 

    - Couldn't set the Origin in CTRL + SHIFT + ALT +C. Don't know where to set origin. 

    So big takeaways.... I tried the whole left side of the UI basically. Everything feels much better, looks better. Things that felt instantly better were the viewport, workspaces, menus being more visible up there than down, things are more organized and are packed naturally. 

    Things mildly annoying, the 1, 2, 3 for selection type. "A" not working as before, "Z" not working as before, also period and coma.

    The hardest thing to discover was how tools function now. The mere act of having any selection tool active is having the whole Blender 2.79 experience, where is hotkey centrist and there are no visual queues. Then as you select other tools in their respective icons, Blender changes radically, now tools don't go away, they stay with you, you don't have to dismiss them and they don't lock the viewport. Also the gizmo is part of those tools now.  

    Result of the PS4 modeling:

    • dostovel Hi Omar, a few hints:

      If you go to Edit > Preferences > Keymap > Preferences > Select All Toggles, you can use select/deselect all with 'A' again. Otherwise it's 'A' to select all and Alt 'A' to deselect all (actually quite handy).

      To get rid of Gizmos: on the top right side of the Viewport there is this icon that looks like a bow and arrow, this is not to wake up Robin Hood, but to turn on or off different Gizmos!

      For setting the Origin there is unfortunately no Shortcut, you'll have to go to Object > Set Origin >...

      You can get the dots in Face Mode back by going to the 'Yin Yang Circles' (right next to the 'Robin Hood' icon), this is the Overlays menu. Open it (when in Edit mode!) and under Mesh Edit Mode tick Center.

      That black menu on the lower left that keeps popping up is highly annoying I think; somtimes it covers the part of the model I am working on;) It's a bit  like the former F6, but without me asking for it.

      Have fun exploring 2.80 further!

    • spikeyxxx Thanks Spikey. The "Center" options for the faces is live saving. 

      I am debating thought if I should left Blender 2.8 with all its defaults. If the developers and people from the Blender Studio made it this way, perhaps they had their reasons and I should try and adjust to it.

      I've been using 2.8 for at least 5 hours and already it feels ten times better than 2.79. Lots of confusing things though. Log #2 already taking shape. 

    • dostovel You can of course leave everything at it's default, but remember that the developers also left open a lot of customizability of Blender; they never said that the defaults are the best...

      As long as you're not making tutorials, I think you should feel free to make Blender the way it works best for you.

      That being said, I do think, that it's good to try the defaults for some time and then, when you can't get used to some things, you can always change them. That is what I did with the 'old' Blender as well..,.

  • Captains Log #2: 

    Met Eevee today. Definitely was like meeting a girl online, flying to meet her in person and turning out to be a nun in a church. I don't know what to expect from her. Her sisters Workbench and Look Dev don't know what to make of them either.

    - Really confused on how wireframe works. By far the most perplexing thing until now.

    - Why if I'm in wireframe view can't I see the vertices in the back? Did dev money ran out?

    - Why when I'm in "Solid View" I can see behind objects as if in wireframe?

    - Why are Objects in Solid View always displayed as having "Wire" and "Draw All Faces" always on? feels like a never ending weird wireframe. I don't want to see all the edges all the time. Give me back my slick sold view.

    - Ok, I see there are now 3 render engines. Eevee, Cycles and Workbench. I have zero idea of what Workbench is.

    - What in the world!? Why when is Cycles and press "Z" and select Rendered, all the wireframes and geometry are there while the viewport is in render activity? now this is some major WTF, does not feel like a Cycles Viewport render anymore.

    - Really confused on what Look Dev is. Can't seem to find its use. Also if I change to the Workbench Engine then Look Dev goes away. Why?

    - Changing to Workbench, pressing "Z" selecting "Rendered" doesn't do anything. Is this a rendering program anymore? 

    - Could this be a Government run program to see how fast people can go crazy?

    - I keep pressing SHIFT + Z to render only to get wireframe view. Looks like that's wireframe hotkey now. Only if wireframe weren't so useless.

    - I was very used to SHIFT  + Z twice to get out of render viewport, doesn't work that way now.

    - I do not like the fact that Workspaces are left exactly how you left them. Very uncomfortable. 

    - Oh great, the wireframe mystery deepens. There's a wireframe slider in the Overlays drop down menu that only seems to partially dissolves the wires in solid view. 

    - Feels like wireframe is not a thing anymore. Maybe working without wireframe is just an interesting new challenge. 

    - Added a Subsurface modifier only to have a mess of wires on top of subsurf modifier on edit mode. Why can't it be the slick solid look like before?

    - Seems I can select vertices in wireframe even though they are occluded, I can't see behind things yet they are select-able though the mesh .

    - Crazy government theory gaining credibility.

    - Face Orientation option very handy and very blue.

    - Looks like things change a lot depending if you're on one of the three render engines. The View Port Drop down has lots of different options and changes according to the engine. But why so many engines? with so many viewport options.

    Biggest takeaways: Wireframe sucks now. 3 major engines that changes a lot how the viewport behaves. Don't see the need for Look Dev. Most of the things have stayed the same on the whole right panel.  

    • dostovel Lookdev is for real-time material creation and texture painting, gives you a good look at your material/textures, without all your lighting setup that you have for your render, so you can always see your stuff clearly. I believe it’s a pretty common thing in other software...

  • I'm not sure why your wireframe mode is looking so strange, Omar.  Mine works just as it should:

    I suggest to you, perhaps download the very newest build of 2.8 from the Blender website, and in the Preferences click Load Factory Settings (it's in the 3-bar menu at the bottom left corner) and try to completely reset 2.8.  Then maybe it should work right.

    Set Origin is in your right-click menu, when in Object Mode!

    The LookDev mode is useful for making your materials - while in LookDev, Blender uses an internal HDRi map to light the object, without you having to establish one by yourself.  This HDRi will not appear in your renders, it is internal to Blender only.  There are a few different HDRi's you can use; in the top right corner of the viewport, click the drop-down arrow next to the viewport select buttons and click the globe to change between the different environments.  You use this same method to change matcaps when in solid shading mode.

    ETA:  If resetting Blender to factory doesn't do the trick, then while in Wireframe mode, click the Show X-Ray button, which is here:

    Blender should remember to turn this on every single time you switch into Wireframe mode again thereafter.

  • The Workbench engine in 2.8, is Blender's solid/wireframe viewport shading mode.  That is to say, even when you've chosen the Eevee or Cycles engines in your Render properties tab, whenever you're using solid shading mode in the viewport, you're using the Workbench engine.  I suppose the devs made it accessible in the engine menu for completion's sake, but there is no reason to ever select it there - and as you found out Omar, if you do select it there, the other shading modes become unavailable.

    ETA:  Oh wait!  I -can- think of a reason to select the Workbench in the Render properties menu!  You would want it there if you want to render the solid-view viewport, either as an image or an animation.  This would be the equivalent of using "OpenGL Render Image" or "OpenGL Render Animation" in 2.7x, except that it will still use your camera.

    • ssmurfmier1985 Alright, Look Dev will get its chance once I'm into shading and texturing then.

      jjakeblended X-Ray should be enabled by default, I mean who wants a wireframe that doesn't wireframe.

    • dostovel I believe X-ray IS enabled by default.  That's why I suggest restoring your settings to "factory"; if you've ever downloaded a 2.8 build any time in the past, the new build could inherit some of the old UI settings from that early build unless you reset.  In the very early days, wireframe was broken and strange, but more recently it's been fixed up to work more like it did in 2.7x.

    • jjakeblended Nah this is the first time I've downloaded 2.8, I don't have any previous settings. I forget this is still on Beta, funky things must be going on. And I guess I'll just have to get used to selections feeling like cheese. If I find I'm eating more than usual, it's probably because of 2.8

    • dostovel It's okay, if your mother is anything like mine, she's always complaining that you're not eating enough anyway (no matter how much you eat).  

  • Captains Log #3

    Got myself into big doo doo today. Using Groups doesn't seem to be a thing anymore in 2.8. Shouldn't have made the Heli almost entirely out of groups in 2.79 then.

    - I used to do Group Instancing. 

    First take a mesh that had lots of parts that weren't going anywhere and secondly group them. Then get any low res mesh and group duplicate it so I can save on memory and performance.

    - Can't find groups in 2.8 to do this. Is the Group system out of the picture now? Then how do we link assets into other files?

    - The closest thing I found was this in in the "Context" tab:

    - I thought that in the "Instancing" menu I was going to be able to do the "Group Duplication" but no, that doesn't seem to be it.

    - It Says "High Flying Bird" up there but as you can see in the image below, there is no Collection named like that. So what is that menu all about? Is the Collection in the "Context" Tab separate form the actual Collections menu?

    - I thought Collections menu was here:

    - Some Collections are grayed out, the meshes are not visible in the viewport but the "Eye Icon" is set to On. Shouldn't they be visible if the Eye is not turned off?

    - If I right click on a Collection Layer, a really big menu pops up with lots of options, I don'tknow what does do yet. Time to test and see.

    - The View Layer has got me confused. I haven't got the slightest idea what that is. It shows that I have 2 but I don't know why.

    - The Heli came better than I expected into 2.8, except for the Group Duplication, those parts are all missing. Only their simple meshes upon which the Duplication was on are visible.

    I am very confused when it comes to this part because it seems it has to do with a totally new system with this Collections and stuff. 

    I'm stuck here, this part has to be learned, not re-learned since it wasn't in Blender before.

    • dostovel in this video Ethan goes over the new collection system and instancing, might be useful 😊

      Watch the whole course while you’re at it, lots of neat stuff about Eevee which might come in handy for learning 2.8!

    • dostovel As for “stuff not being visible but the eye icon is on”, maybe this issue waylow pointing out in the thread description is the problem:

      We're talking more like "My collection is hidden and greyed out but the eyeball icon says it visible - what's going on!?"

      Turns out that you have the collection "disabled" in the viewport, but that toggle isn't visible in the outliner because that filter is not enabled.

    • ssmurfmier1985 No, no, no , nooooooooo! I have become one of those people. I should've read before I freaked out.

      EDIT: Thanks Miranda, that video completely cleared up my Grouping doubt. It's all done now through Collections, there is no such thing as group now. Question is, how do you link assets into another file now? Lets do some experimenting and see. 

    • crew

      dostovel You link  a collection the same way you would a 'Group'

      'Groups' are planning a comeback, but they will be different to the old groups.

      Collections, have a few issues when they are linked.   eg - you can't drive the visibility once it is an instanced collection, and when you make a proxy, the name of the proxy is the name of the Collection, not the name of the object in that collection that you that even a word?  Is now!

      Also there is no way to hide objects in an instanced group (linked or local) like you could in 2.79.

      I'm hoping all these quirks will be fixed.

    • waylow Lol proxified. 

      Something is driving me crazy and it's that orange glow of selection that goes through objects. I can't find were to turn that off. I know I can toggle off "Outline Selected" but that is not it. I would like the selection not to phase through objects. Also the super thick orange stroke is making me hungry for some reason. Please tell me there's a way to change this. 

    • dostovel You can change the thickness of the line in Preferences > Themes > 3D View > Outline Width, but 1px, which I think is the default, is as small as that line can get I'm afraid.  I don't know if it's possible to turn the x-rayed selection outline off.

    • waylow theluthier I may have found a bug. 

      I'm trying to understand Instancing and I've notice you can't use a mesh to instance, so unlucky me,  since that is exactly what I'm trying to achieve, to have a mesh instance a collection.

      The thing is, this Cube is in Collection 2 and when I select it, in the Instancing Menu Collection is not there.

      How ever if I select an empty, Collection appears in the Instancing Menu...

      Which freaking sucks because in the Heli file I had meshes as instances, not empties. No I can't convert the meshes that are in places into their respective instances.

      So anyways, since the Cube is in Collection 2, I select the Empty, select Collection and find Collection 2, and now the empty is instancing the cube.

      If I tick off "Display Instancer" (which only is supposed to hide the empty) and try to select the instanced cube, blender goes crazy and for some reason starts selecting the camera and the instance cube gets lots in the ether. 

  • I have all this circle meshes that in 2.79 were instancing groups, they are parented to the bones in the rig and all.

     All I have to do is to get those meshes to instance their respective collections, but meshes wont accept instances, only empties. Any ideas? 

  • Captains Log #4

    Saw a pigeon today, flying freely in the sky. Sometimes I wonder why I went into this line of work,with all its comings and goings... I could've had a Bakery, making delicious bread in a nice town. 

    And the thoughts continue....

    - There is something I don't know if it's a glitch or this is how it goes. Instanced objects selection feels wonky. Say you crate an Empty and Instance a Collection into it, when you select it, it behaves normally, the stroke of your selection is visible...

    -But if you create more instances of the same thing, the selection highlight doesn't appear.

    - The stroke highlight doesn't appear. It is hard to tell if you have anything selected this way. Why doesn't it just behave normally and highlight my selection?  

    Funny thing, if I'm in wireframe mode and select the original one, they all appear selected, even though only the original one is selected.

    If I select the 3 copies and leave the original un-selected, I get nothing, no highlight of selection. That is very uncomfortable when you're selection objects and you're not even sure what you have selected.

    - Where are the Collections that are not in use? As long as is even possible. The Heli file in 2.79 had several groups that when I opened it in 2.8, those Groups got interpreted as Collections. When I SHIFT + A and at the bottom in Collection Instance, when the list pops up, I can see the names of all the groups that were in 2.79 that are now Collections

     Yet they don't appear in the Scene Collection Menu.

    And when I go into the Blender File, it lists the Collections there with Geometry in them, yet they are nowhere to be seen, not even in the viewport.

    - Is there transparency in the viewport for geometry? In 2.79 you could enable "Transparency" for an object and in the material lower the alpha to have transparency. I can't find how to get transparency in 2.8

    - Ok ready to render, ready to render, aaaaaaand.... no big render button? or render animation button? Perhaps I'm in the wrong engine? How can this be? F12 just turns up the volume in the computer. Do I really have to go to Render --> Render Image, every time? I refuse to believe there is no Render Button. What am I doing wrong?

    - Overlays and all kind of stuffs are visible during Viewport Cycles rendering now? In 2.79 when you kicked off the viewport render, non render-able went away and only the clean render was left. How come this is not the case now, feels very weird. Do I have to turn on and off the overlays every time? Is there a setting somewhere to get the old behavior back so Blender does it automatically for viewport renders?  

    - Why when I select and object and Numpad / to view it on local mode, if I kick off a viewport render all the other elements suddenly pop back up again, as if it got out of local view, but then if I cancel the viewport render, everything goes away again and it's back to that sole object in local view. Must obviously be a glitch?

    - This "Indirect Only" filter in Collection was making me loose my mind. 


    Not all the icons in the Collections menu are visible at the same time unless you turn them On in the filters. Icons being hidden by default can be a big problem.

    The squiggly arrow being "On" for the objects inside that collection "Hoover-Engine"  was making things non-render-able. When I rendered, objects inside the Collection were't showing in the render and the little squiggly arrow icon in the filters was off, so I didn't see the icon was enabled for that collection making me waste a lot of time trying to figure out what was going on.

    - Still a bit confused on what the TV icon does. Globally disable in viewports? Does this mean in the workspaces areas?

    - Don't know if there is a way to re-order the workspaces tab, it seems as I can click and drag them to the order them as I want, but it doesn't let me. Is the only option right click and "re-order to front"? That doesn't help that much.

    - I have no idea how I can now link the Heli with its rig in another file in 2.8 if Groups are no longer available. In 2.79 you selected which layers were visible when the linking happened, can we do that with collections? How about linking assets in another file and then CTRL + ALT + P to Make Proxy, will that still be the case now?

    • dostovel 

      - Overlays can be overlayed on anything (even on top of Eevee and Cycles), that’s it’s power, so yeah if you don’t want to see it in your viewport render then you have to turn it off manually.

      Not all the icons in the Collections menu are visible at the same time unless you turn them On in the filters. Icons being hidden by default can be a big problem.

      - Only for existing projects (from before these were hidden), I don’t foresee any problems in a fresh scene as you will adjust it to fit your needs while going along.

      - the tv icon permanently hides it. If you use the eyeball and use alt+H to unhide something, the eyeball stuff comes back too. But if you use the tv icon it will stay hidden.

      - for linking you will now select a ‘collection’ instead of a ‘group’. Creating a proxy still works the same. But I think waylow can probably explain this a whole lot better than I 😊

    • @smurfmier1985 Good point, if you start a new scene in 2.8 yourself things should flow better when it comes to icons in the Collections. Problem are bigger when you open stuff from 2.79 in 2.8

      I guess I'll just have to get used to the fact that overlays are in the viewport render now. 

      Ah now I get that TV Icon thing. That sounds pretty useful. Thanks Miranda. 

      Do you know what View Layers are for? that still eludes me. When I opened the Heli file in 2.8 it came with two View Layers but I don't see the difference or its use. 

    • dostovel I didn’t yet, so I asked professor Google:

      View Layers

      Render layers have been renamed to view layers, to indicate their expanded scope. Besides splitting up a render into multiple layers for compositing, they can now also be used as multiple views and variations of a scene for editing. Different windows can show different view layers, by selecting the scene and view layer in the top bar.

      Collections can be excluded from specific view layers with the checkmark left of the name. They can also set to contribute only indirect light and shadows, or act as a holdout mask. These settings are edited in the outliner now.

    • ssmurfmier1985 Well that's a mouthful. For now lets just say they are the new render layers in someway. Never had I in Blender used the Scene option, that was always kind of confusing, setting them with linked objects or not and this an that. Now add View Layers into the mix and it all feels quite daunting. 

      In the scene I opened from 2.79 it says I have 2 View Layers. I wonder were 2.8 got that from. And it certainly feels like View Layers and Scenes go by the hand, they are set one next to the other. 

  • I have hit a rather unusual roadblock ......

    I went to and downloaded the 2.80 Beta , unzipped it and installed it, but when I open it, it says 2.79 on the splash screen but has eevee as an option and has 2.80.1 on the top toolbar (see screenshot) 

    It also looks nothing like the 2.8 I have seen so far and was expecting to see. I can only assume I have made an error in downloading /installing or that my computer has somehow crossed wires with the 2.79 I already have installed. Can somebody please point me in the direction of the right download and explain the best way to install it , or tell me where I have gone wrong.

    I am only now returning to blender after a 2 year hiatus and am very rusty..... 


    • frikkr Matt's alive everyone, worry not, he's ok. 

      silentheart00 Silent can probably tell you, I think that's the issue he ran into when doing Project Portfolio C out of Google Drive. 

    • dostovel Haha , yes Omar , worry not , for I am ok :)  Just had to take a long break from Blender , but I am back. 

      As for 2.8 , I think I will take ssmurfmier1985 's advice and just wait it out until the official , bug free release ( which hopefully has an installer) I have very limited time at the moment for Blender , as we have two screaming babies that come first now , so I dont want to be wasting what time I do have , pulling my hair out with bugs and issues......

  • Captains Log #5

    waylow "Tips for Fixing Animation Data" tutorial saved me a lot of time, a lot of time. If Wayne had kept that knowledge for himself, I would've wasted a lot of time, a lot of time. Sharing accomplishes much more than competing. Innovation is faster when you stand on the shoulders of giants. I should open that bakery. 

    - What is up with the new Timeline? You can't see at all where the first frame begins and the last frame ends. You can't see markers well either. Hard to work this way.

    - After hours of working this way, turned out you just had to pull up the timeline. Very funny Blender. Very funny.

    - In Blender 2.9 the names of the Markers in the Timeline were "Scene_1, Scene_2" and so on. In 2.8 the names changed for some reason. I want to change the names of the Markers, but Blender wont let me. I I go to Marker --> Rename Marker but apparently it glitches out because the name doesn't change. Or maybe since the markers are Bind To Camera, it takes the name of the Camera? Also that's why it has the camera icon? I want to change the name either way. Blender mister dictator now. 

    - Got a bit frustrated for a while there because I was used to moving the scrubber in the timeline no matter where the mouse cursor was at, now you have to specifically grab the blue head of the scrubber to move it. Right now when Blender acts out, you think everything is a glitch. 

    - Yellow Keyframes bar no longer appear in the timeline. Glitch?

    - In 2.79 in the timeline I could hit S and it cut to start in that frame and hit E and the timeline got cut to end on that frame. Can't seem to do that now and the menu doesn't show any hotkeys. 

    - This Ribbon sometimes is at the bottom, sometimes is at the top, sometimes it's not there, its hidden, sometimes is there, visible. Don't have any idea on how to achieve that, to move it to the top if I want it at the top, down if I want it down, hide it or make it visible. 

    - The little stripes at the corners of every window that let you split windows in half are no longer there. I thought we couldn't split windows anymore because of the Workspaces tabs, but it turns out you can still split the windows, it's just that the stripes are no longer there. Very misleading. Why not just put the stripes back to signify that? 

    - I have noticed that when you select a collection in the collections list, right click then delete,  the contents that it has inside doesn't get deleted as well, the whole batch of its content gets move out to the global scene instead of being deleted and if you had that collection hidden then suddenly all it contents will show up in the viewport, creating a horrible mess. Would like that deleting the collection deleted the contents inside as well. 

    - Spent a lot of time trying to figure out how to make the rig a proxy in a linked scene, because it was duplicating it. Two rigs were showing up. Turned out you have to mask it with the Holdout icon so it doesn't show in the linked scene. I hope this is the right way to do that because in 2.79 you just selected which layer you wanted to remain visible.

    • crew


      Yep - the timeline is now like the dope sheet.  Try to middle mouse around (up/down) until you see all the keyframes.  They are keyframes like the dopesheet not the old yellow lines.  It is likely just showing you an area underneath where the keyframes are.

      (This annoys me in the dopesheet too - It only has occurred to me to report it just now haha)

      -And those markers are Camera bound so I'm not sure if the rename will work. You might need to unbind it first but sounds like that is a bug anyway.

      -Setting the start and end frame in the Time line is now (Ctrl Home and Ctrl End)

      E and S will Extend and Scale the selected keframes.

      -When deleting collections, try 'Delete heirachy'.  That will delete everything.

      -With the 'Header' (you called 'ribbon').  In 2.8, it is at the top by default.  In 2.79 is was at the bottom on most windows.  If you open an old file it is likely to be at the bottom.  You can right click in the area where it should be and then a menu will pop up.

      (hidden, I know!)

      -Linked collections are a nightmare.  I'm trying to figure out a way of doing exactly what you are talking about.  I will try the Holdout option.  (It wasn't working the last time I tested it)

      Keep this stuff coming Omar, because if you struggle with something, it means someone else has also struggled with it.

      We'll collect all this stuff and try to make it into short videos that will help save a lot of people a lot of headaches.

      PS.  It looks like you are using the "Add Camera Rigs" add-on I wrote.  Just so you know, there's a new version coming out really soon. (I've fixed all the 2.8 bugs and now I need to submitt it to the Blender devs to get it included in the release again.  The version that ships with blender 2.8 has bugs)

    • waylow Oh that's right! I had forgotten to ask, I saw your name when I enable the add-on and I was like, hum, could this be Wayne, Wayne? That's awesome, I feel like this gives me street cred, like dude don't mess with me, I know people. 

      I've been using that add-on a lot lately, very handy. I'm amazed to see now that the timeline has up and down, not only left and right. You are correct, the keyframes were lost up there somewhere. Who would've thought. Only one axis way from full 3D timeline.

      It seems that when you bound the camera to a marker, the marker inherits the name of the camera and it wont let you rename it. You have to change the name of the camera instead. Kinda pushy but ok. 

      Thanks for the other tips, little by little 2.8 is making more and more sense and feels more and more buggy. 

    • crew


      Hmm I don't want to get too off topic but maybe I can add that as a feature to the add-on (naming the camera I mean)

      At the moment it will try to name the camera and rig  'Dolly_camera' and 'Dolly_rig' respectively but if that is taken it will add a .001

      What are you trying to do with camera name?  Using it to mark the name of the shot?

      frikkr , I know exactly who you are.  We are brothers in arms fighting the same fight daily.  You know what I'm talking about ;)

      Re: Collections.  Yep, they are pretty much jazzed up versions of Photoshop layers/groups.

      I use them to keep everything tidy and logical.  But make sure you check out the filters (the little funnel), somethings are hidden by default and it can get really confusing.  (we'll do a video about this)

      Also remember when you open an old file, it is going to look different to the new default layout.  So you can try unchecking 'load UI' if you don't want it to look different to what the NEW normal is.  (The transistion is a mind bend if things are in different spots on each file)

    • waylow Yes, naming the shots at the markers as reference points. But I'm guessing hijacking the name of the marker when you bind the camera is Blender's own doing? At first it was uncomfortable because I didn't know what was going on, I was trying to name the marker but it was changing the name back, now I've been getting used to it. If I want to change the name I just go to the camera and change its name. Although those being independent wouldn't be so bad either. 

      But if I may, I was looking for a way to use the target of the camera rig as a depth of field Focus Object, but then I wanted to aim somewhere else and have the depth of field focused elsewhere so like always I ended up using an empty to be the driver of the focus object. Would be really cool if the camera rig had a mechanism that allowed for a focus object and control everything from within the rig. Is something like that possible?   🙈

    • crew


      Would be really cool if the camera rig had a mechanism that allowed for a focus object and control everything from within the rig.

      That's on my to-do list.  I want everything to be controlled from the 1 object (the armature).

      I also hate having the Dof_object separate from the rig but Blender doesn't allow it to be a bone, so I've been trying to figure out a way to drive the distance with some type of auto calculation.

      To be continued when I get a spare second or 3.

    • waylow So if Blender allowed it to be a bone it would probably be much easier, right? Could it be possible to communicate with the blender devs and see if they do their thing and conjure a magic trick and Blender could accept bones in the DoF field? Maybe  now could be the best time since they are doing lots of changes for 2.8? Who do we have to bribe? I got two dollars here.

    • waylow Couldn't you just Parent an Empty to the Bone (I know you can..)?  Or am I completely missing the point?

    • waylow Thanks Wayne :) I hope all is well down under. I am super excited to get back into your animation course. I had just got the hang of walk cycles and then we suddenly found out we were expecting twins and everything got put on hold. I dread to think how much I've forgotten but ill soon find out when I get back to animating in the coming weeks once I fathom out 2.8 :P 

    • crew


      That's what it does already, but my plan is to have everything animatable inside the one object, so only animate 1 thing there is 1 action created.  Right now you have to animate 3 things.

  • Ok so I couldn't help myself and I decided to try 2.8 and now I'm hooked! Sorry ssmurfmier1985 , I ignored your advice to wait :( 

    I have decided to use my campaign to get to grips with 2.8 to ressurect an old project that I had given up on long ago - that way if anything goes worng then I haven't really lost anything too important or wasted any time. 

    However , I already have questions and they are just going to keep coming : 

    First up : collections.... I watched that video that you recommended to Omar ssmurfmier1985 , and it did help, but are collections a jazzed up version of layers? My old file was nicely organised into layers but after opening the file in 2.8 , all of the objects seem to be randomly put into various collections that don't eem to correspond with the layers as far as I can see. Should I re-organise them into collections as if I was placing them into layers? From what I can see, the new collections system seems to work more along the lines of Photoshops layer/grouping system - am I right? 

    Secondly : how do I go about saving my startup file? I have two monitors and I always had a Blender workspace set on each and saved as a startup file so it was always there when I opened Blender. However, the option to save startup file seems to have gone AWOL....

    Thats about it for now , but there will be more to come as I delve deeper into the depths of 2.8 whilst also tring to  remember how to use Blender as I haventused it for nearly 2 years :P 

    Oh and lastly, Hi waylow , not sure if you remember me (FrikkR) but i'm back! 

    Aaah , how do you turn off type overwrite in this thing?!! Everytime I go to edit what I've written , it types over what iv'e already wrote - Hence all the errors that I can't change......

    • frikkr lol it was just a suggestion because the new courses are coming pretty soon, but 2.8 ROCKS so I don’t blame you 😉

      Collections are indeed a new and improved layer system with a lot more features. The Blender Manual on collections can explain it better than me 😊 but they are definitely more like a normal folder structure and they are the best!!

      Since you are just starting out again, I would actually suggest to start a fresh project, because old files usually don’t transfer well to 2.8... it probably would save you quite a headache to not try to get your old stuff to work. How about joining us in the vehicle community challenge I’m hosting this month? Just create a simple scene you’re comfortable with and have fun exploring 2.8 😄

      File -> Defaults -> Save Startup File (according to the manual)

      Hope this helps!

    • frikkr Hi Matthew, one thing I know,  Save Startup File is now under: File > Defaults > Save Startup File

    • ssmurfmier1985 Thanks! 

      I would love to join you in the challenge , I actually won a couple myself back before I had to take my break and I loved taking part in them. However, at the moment my time is very limited and I doubt I would be able to complete something in time. Plus I have two huge projects on the backburner that I really want to get back into asap ( an animation series about a toy bear , and a point and click adventure game - both of which I invested several years in between 2014 and 2018) so you can understand why I want to get them going again. 

      Luckily, I have tried the files from both these projects in 2.8 and other than the layers issue, they seem to have transferred fairly well (which is a huge relief because I need them to complete those projects and some of the files are literally hundreds of hours of work that I can't afford to have to start again) 

      I will follow the challenge closely , even though I wont be participating. 

      Also , please check out my old Polybook here :  if you want to see what I was up to back then - although I noticed almost all of the comments and a few posts have gone missing, so I will have to update it. 

      Thanks for all the help, it is great to be back in this community again and to see that it is still as friendly and helpful as it used to be :) 

    • spikeyxxx Thanks for the advice :) much appreciated and its great to meet you. Good luck in the challenge also btw . 

    • frikkr Fair enough 😊 good luck with your projects, and be sure to share your progress in your polybook because I want to see!

      (There will be a Halloween Challenge in October and an Animation Challenge in January, btw 😉)

    • ssmurfmier1985  frikkr I say you go crazy and make them hardcore challenges daily yeeeaahh 

    • dostovel Laughing out loud!

  • This 'Preferences' menu, which can be found in the Keymap tab seems to be only available with the default Blender keymap? 

    If you switch to a different Keymap profile, this menu disappears. and the settings you set here are ignored.

    I believe in older versions of 2.8 this menu used to be in the Input tab. 

    Interestingly any profiles that were made/derived from the default Blender keymap will respect the settings you set, but the menu just isn't visible

    • aarvz I am not sure I understand what you mean, but you can always go to Edit > Preferences and there you can adjust all your settings:

    • spikeyxxx 

      Switch your keymap profile to something else (like Industry Compatible) and notice that the Preferences menu at the top disappears

      For some settings like spacebar action, it makes sense that this is default Blender keymap-specific as this can be customised individually on other keymaps, but there are other settings like Extra Shading Pie Menu Items which simply adds extra selections in the Z shading pie menu

      Though I did just figure out that the extra shading pie menu can still be achieved in other keymaps by changing the Shading command name to VIEW3D_MT_shading_ex_pie 

    • aarvz I sort of understand now what you mean, but there doesn't appear to be a Shading shortcut in the Industry Compatible Keymap.

      At least it's not 'Z' and I could not find it in Preferences > Keymap > 3D View, so I don't think this is 'strange behaviour' or something.

  • I am keeping BOTH 2.79b and 2.8 beta on my PC, because I oftentimes download blend files from websites and I'd like to open them in either version. When 2.8 stable gets launched, I will still keep 2.79b on my computer. 

    As to learning 2.8, it is really one step at a time. If I find 2.8 too daunting to learn, I just view tutorials and simplify everything by using digital notebooks via Google Slides. I take screenshots of tutorials and attach brief notes to them. 

  • Captains Log #6

    It seems I'm going to get out of this alive, I can see the shore now, the light at the end of the tunnel. The road was hard and full of terrors. 

    - I've been trying to do a playblast of a little animation but I can't find the OpenGL buttons to do viewport renders. Were those taken away? Has it been move to the Workbench engine or something? or perhaps OpenGL renders were so yesterday and nobody was using them to begin with. 

    - What is this menu on the right side for? The lighting / color / options. I change the settings but the viewport doesn't do anything.

    I have to change settings in this menu that is on the drop down on the viewport, only then do I see changes on my scene. But then why do I need the menu on the right side for if it doesn't change anything?  

    - When different rigs are all at once in the scene, if they are all in Pose Mode, if you select with A, all bones get selected no matter if they are from different objects rigs. In 2.79 rigs were independent, if I entered Pose Mode in one rig, you could not select posed bones in other rigs if you hit A, yet in 2.8 you can, all bones seem to be active as if all posed rigs lay open. 

    - Where are the three little icons that used to copy paste keyframes and or pasted them flipped  when doing naimation? I can only see those icons in the modifiers tab of the graph editor, so they exist, the question is, why remove them from all other places? They were very handy.

    - Simplify doesn't seem to be working at the moment, it's all buggy. Sometimes some objects receive the simplify, sometimes others don't and sometimes it straight up doesn't work, sometimes you have to restart Blender and you might get lucky and it works. I guess it's just a matter of waiting for the all powerful devs to tackle it.

    - Another thing that isn't there anymore, I used to press shift and drag in the node editor and the strings would unite by one of the yellow dots. Has that been taken out? 

    - Blender no longer asks if I want to "Reload Trusted" and in the preferences there is no longer an entry for "Auto Run Python Scripts". Is that no longer necessary or is there something else that we have to do?

    - So in the end this is the only way to render? There is no main big Render button like before? That I can't believe. 


    • dostovel 

      - In the viewport under the 'view' menu button, you can choose 'viewport animation'.

      - I think the menu on the right is the render output if you use the workbench renderer (maybe it’s visible in lookdev?I dunno haven’t tested/used it). 

    • ssmurfmier1985 Ah thanks Miranda. I'm guessing that with a pretty viewport now, viewport rendering will be much more useful.

    • dostovel Shift and drag still works if you change from default Box Select to just Select (the blue Icon top left):

      Auto Run Python Scripts is in the Preferences here:

    • spikeyxxx Dangs I did not see Auto Run Python Scripts there. So why in 2.8 aren't files at the beginning asking if I want to reload trusted? Maybe they are and I am missing that as well? those quick messages now appear at the bottom but it is not showing there either.

      I skipped that step in the instructions for rendering the demo reel in 2.8, I hope that reload trusted isn't appearing on other people when they open the file to be rendered. Now I'm a bit freaked out.

    • dostovel I don't know, but I tried to open an old file from the animation bootcamp and I got this:

      I'm sure you couldn't have missed that;)

    • spikeyxxx I am not getting that no. That looks and reads so ominous. If that thing popped up on my screen I'd quickly unplugged the computer from the wall socket and ran to my mom. 

    • crew


      Just so you know Spikey, there are 2.8 animation bootcamp files available ;)

      But I know you were just demonstrating the error message...not the fact that I created something this is now broken haha

  • Are MatCaps a thing in 2.8? Iv'e tried looking them up in the manual and there isn't anything on them, but a quick google search suggests there is. 

    It does make sense to exclude them as you could easily add a glossy material in eevee or that lookdev thing that I haven't got my head around yet, but it was always so handy to stick a matcap on when you wanted to see how straight a car panel was for example , without having to mess about with materials. 

    If they are there , then how do I access them now that the N panel is much more streamlined. 

    A few other things I cant see in the N panel when modelling , that I used to use frequently were background images , and edge/face measurements. If anybody could point me to those that would be great too :) 

  • I've just come across something crazy in 2.8 and I'm really hoping it is a new feature and not a bug because it will be awesome - I accidentally switched to edit mode when I had two different objects selected in object mode, and was able to edit them both! This would be an amazing feature especially when aligning geometry up with other objects that are supposed to fit tightly together. The screenshots below show what I'm talking about : 

    Two seperate objects selected , one highlighted yellow and one orange : 

    Enter edit mode and both are editable : 

    • frikkr Yeah it's one of the coolest new features of 2.8, it's not a bug. Although can you imagine if that had been a product of a bug in your computer? dude your .blend would be worth billions, devs from all over the world would line up at your house to see the wonder, Shakira would throw a concert in celebration. That screenshot would have been famous. 

    • dostovel Hahaha if only eh :P 

    • frikkr Has 2.8 been locking your computer down, Matt? Windows keeps crashing for me, it freezes up and I have to force restart by holding the power button on the laptop. And more times than non it has been when exporting a video. There are a lot of errors and glitches and bugs and crashes and crazy and oh boy, and even then I can't go back to 2.79 now. 

    • dostovel Ive been using it for a week now Omar and I haven't had a single crash , glitch or bug . Im actually quite impressed at how smoothly it is considering it is still in Beta . 

    • dostovel Never crashes for me either Omar... even in Alpha I had very little crashes. Might be because you're converting your 2.79 scene, or maybe because you do lots of advanced fancy stuff we mundane humans don't do 😉

    • ssmurfmier1985 I wish I'd be one of them fancy fellows that uses drivers, rigs, math nodes and python.

      I don't take coffee, I take tea, my dear
      I like my models done all quad
      And you can hear it in my accent when I talk
      I'm an average user in CG.

    • dostovel This brings hope to all of us still at the bottom of the CG mountain looking up an seeing you standing at the top 

    • ssmurfmier1985 Take my hand.... behold the horizon!

      This here is but the first peak, this was only base camp, look how many other elevations there are. That there is Mt. Rigging, is where everyone goes to die. I'll try to summit Mt. Lighting next, is a short but treasonous path, watch out. Now climb back down, you're not doing any favors taking shortcuts. 

    • crew


      I've had a tonne of crashes - and yes, for the first time ever it has crashed my OS.

      I'm on Mac OSX (glad to see it's not just me having these issues)

  • Anybody know how to scale a face loop on its normals in 2.8 ? Im sure it used to be ALT S , but now that shrinks/fattens........

    I want to scale the selected face loop in on itself so the diameter gets smaller without the faces getting shorter or the whole thing sinking down inside that nut : 

    Also , I'm sure when scaling an object on an axis , if you tapped that axis again it would switch from global . to normal , and then finally to whatever you had selected in the menu for the gizmo - for example Normal , but it seems in 2.8 it will only switch between global and local , meaning you have to activate the gizmo and use it to scale on an objects normal , gimbal , or view , which is a minor inconvenience but was much easier when you could just cycle through when scaling by hitting the axis you were scaling on - am I missing something here?

    2.79 example of what I used to do :