yukino hatake (yukinoh1989)

5 replies · posted

Problem with animation path.

hello guys . once more i have a problem.
i decided to give the character ball already a go and take it slowly by building up bit by bit till i have what i want.
now i started out with dougie and noticed a problem from the start. 

i changed the direction of dougie and afterwards set keyframes for his body and tail (i left the root controller where it was)
then i started animating really roughly and noticed the curve path is out of position compared to dougie himself?
anyone that can help to fix this problem ?

  • I'm not sure I can provide an precise answer to a problem I didn't fully grasped but if It can help:
    CTRL+Scale and rotation everything before you parent and keys.
    You said to start with the dougie, from the graph seems the ball should be first - saying this, I'm not sure to grasp your needs so I write in case it can help.


  • yyukinoh1989 

    There are two things you should be aware of with motions paths. First is that you can define where they start from the bone; either the head or the tail. Make certain you pick the one that makes the most sense.

    The second thing to watch out for is that motion paths do not update properly by themselves. They do so according to the official Blender docs but in practice they do not. Hugely annoying...

    When a motion path gets "out of sync" you need to manually "update" it. Fastest way to do so is, with the bone selected in pose mode, press W and  choose "calculate bone path".

    Now it will be in sync with the animation again untill you make another change in the dopesheet or graph editor. Motion paths are just hardly functional. From what I checked in 2.8 its not much better (despite the deps graph refactor).


    • 3dioot Thank you so much. it indeed was been caused by the option head or tail . never knew what the diffrence was xD
      pprocyonlotor thanks indeed its someting i sometimes tend to forget . is there a way to fix that so that next time when i open it he will automaticly run it correctly without me having to click reload trusted ?
      donbonbon thank you it didnt solved the problem but thanks for the info :)


    • yyukinoh1989 there is.  you can enable "auto-run python scripts" in user preferences-->file. the downside to this is that if you ever download a .blend with a malicious script, it could get you in trouble.  As long as you are cautious and remember to toggle the setting or set the proper exceptions, you'll be fine, but I usually just reload trusted.

  • also, this may be unrelated to your current problem, but just so it doesn't end in trouble down the line, your animation_dougie278.py script isn't being run due to Blender's default security.  Be sure to click "reload trusted" on the top bar if you want to run that script (you probably do), though you may want to save first.