Vue Thao (euv)

11 replies · posted

Comparing Cycles

I hardly see any difference between the two versions, the original and cycle x, when it comes to quick rendering by using the cycle engine. 

My  specs are: AMD A8-7410 APU with AMD Radeon R5 Graphics 2.20 GHz, 8 gb RAM, 64 bit 

Not sure what's the problem with my PC doing its job ever so slowly. 

  • At the moment CyclesX  is mostly faster on complex scenes, but you are way too slow anyway.

    I render a scene like that with a 1920*1920 resolution, 128 samples  in under 16 minutes on my 10 year old CPU:

    AMD Athlon(tm) X4 750K Quad Core Processor × 2

    (Blender 3.0, but that doesn't make much difference compared to 2.91)

    So you are right that something is probably wrong with your PC. Not so much with your specs....

    • Is AMD Radeon R5 Graphics slow compare to AMD Athlon or it has to do with the RAM + SSD?

      I just upgraded my PC with a new ram and SSD in 2019. I ain't a tech guy so that's why I'm asking. 

    • Definitely your PC.

      2 minutes on a simple scene like this is pretty big, a complex scene and your probably talking hours with your set up.

      AMD A8-7410 APU with AMD Radeon R5 Graphics

      AMD's Accelerated Processing Unit with Integrated Graphics are OK with most games, but not ideal for 3d software.

      When using 3d and AMD graphics cards you will need to install AMD's Radeon Pro Software for Enterprise Software drivers, unfortunately I don't think it is available for integrated graphics.

      Would I be correct in saying based on the information you have given you are using a laptop?

      You will have to do some research to see if you can upgrade your graphics card, if that is an option for you.

      I'm using an old PC, originally with AMD A10-7800 with Radeon R7 graphics. I replaced the integrated graphics with a RX5700 graphics card, and this scene will now render for me in under 1 minute, previously would have been around 10 minutes.

      Because of the extra power consumption I also had to upgrade the PSU and extra cooling fans.

      For now check your setting. 

      Go to Edit > Preferences and under system check your render device is activated.

      In the Render Properties with the render engine set to cycles make sure you have the correct device selected.

      And still in Render Properties go down to Performance under Threads dropdown  make sure Auto detect is selected for threads mode, and try different tile sizes start with 32x32 then double it to 64x64 and then 128x128 and try again with 256x256 It can vary between devices which is more efficient. I found 64x64 best for my CPU but 128x128 best for my GPU. You may find you can reduce your render times quite a bit.

  •  adrian2301      

    Here's my result comparing blender cycles on my Macbook (w/ Nividia as not a video game) and Windows 10 (w/ AMD Radeon graphic card). On MacBook, navigating around in blender seems quicker however when it comes to rendering it's slow.  On Windows 10,  navigating around in blender seems to lag a little bit but when I rendered it's faster. 

    MacBook 


    Windows 10


    Blender doesn't support Nividia and there's no option to choose CUDA on MacBook. On the other hand, Blender supports Windows like the picture below. I think having a video game card is kinda cool though especially it comes to rendering. 

    • euv , Interesting!

      You may find Windows is lagging sometimes when checking for updates or anti-virus software is scanning your computer and lots of other windows processes can be annoying sometimes.

      I have windows updates paused and check for updates when it's convenient for me, same with anti virus. I just have to remember to do it fairly regularly.

      If you Google 'Windows Performance' you will find lots of tips and tricks for speeding up your computer.

      I'm sure you can reduce those render times a little more.

      How did you find adjusting the render tile size? You wrote the tile size on the MacBook images, are the Windows 10 images using the same?

      In the System Preferences try turning off the APU device and see what happens. There is no global set up that works for everyone, You will need to try different things based on you computer.

      I have heard lots of people with Mac's having issues. Window's or Linux looks like the best options with Blender, but I think they are working on better support for Mac. Is your OS version on your Mac up to date? 

    • Hey euv ,

      Check this out Blender Manual It's talks about AMD graphics and drivers.

      Manually update drivers from AMD and not rely on windows updates. I have had issues in the past, since I updated my GPU I always go to AMD for driver updates, I no longer get many of the past issues.

    • adrian2301 

      Yes, I had turned off the Windows update. I still have McAfee antivirus program running on my laptop. It doesn't lag the PC instead it also gives a boost to the computer. ;)

      You're right. I forgot to mention the performance setting under render property for Windows. Oops! hahaha
      Before I made the demonstration, I did adjust the performance of 180 (x and y) for Windows.

      At first, I didn't use a GPU device and rely on a CPU, my rendering takes longer about an hour. I used to think GPU takes longer than CPU. When I tried using GPU to render Suzanne the Monkey scene for a second attempt, both computer and blender run perfectly fine. It likes I gotta let GPU warm up after initial rendering. Pretty much similar to starting and warming up the vehicle in the wintertime. When I made several renderings on Suzanne like I did in the demonstration, GPU has no problem crunching kernel numbers at the top of the render tab. 

      Yeah I did download the latest blender version (e.g. 2.81-2.93) on my MacBook. Turned out it keeps crashing whenever I touch the matte (shadow and cavity) setting. Arrrgghhh it drives me crazy. So I had to delete them. The build 2.79 beta seems to work perfectly well so I decided to keep it and use it. 

    • What about your Windows machine ? Do later versions of Blender work OK ?

      This is from Blender:-

      Blender took a big step in version 2.80, bringing amazing features but also breaking compatibility with certain hardware and features.

      Looks like your stuck with 2.79 on your MacBook. I don't think it's possible to upgrade the GPU on a MacBook, I don't own one but I think the GPU is soldered onto the motherboard.

    • Before I upgraded my Windows,   it got issues with the new blender versions. Some of them crash and some others don't respond to the shading properties (solid, dev, render).  Once I bought the rams and SSD and installed them in my Windows, no issues with any blender versions, old and new.

      Yeah from now on I just model anything in blender 2.79b on my MacBook. The funny thing is my Mac doesn't have Numpad.
      I had to go to the preference setting and check the box to turn on emulate Numbpad so the numbers at the top of the keyboard will serve as viewers (e.g. 1 = front, 3 =  right side, ctrl + 3 =,left, 7 = top)

    • I just downloaded and install Catalyst Driver for my AMD graphic card.

      These drivers may help boost my APU, but it won't allow me to launch Blender 2.91. It keeps rejecting the blender program each time I relaunch.  When I launch Blender 2.79b, it doesn't affect that version at all. Idk why probably doesn't like 2.91. hahaha Anyway, I uninstalled it ASAP. After that 2.91 can be launch again.

    • There have been so many changes in Blender over the last couple of years, some issues arise now because of older hardware. At least support is still available for older versions of Blender.