Gradient doesn t worg

hi, 


when i put the gradient node, with the mapping node connected by the objet socket, the column is tottally black , i don t understand. i tried with a default cube with new material and gradient an it's work !


could you help me please 

thanks by advance from Paris 



  • Hi denis,

    it is hard to se with the resolution of your screenshot, but something seems to be off with the X-Scale in your Mapping Node.

    Compare:

    with:

    also, the Y-rotation should be 90° (but maybe you haven't reached that part in the tutorial yet ;)

    Alternatively, you could do this:

    because you are going to create a hard cut-off anyway, and then you can use a Greater than, to flip the black and the white part and use the Treshold to decide where (vertically) the separation is...

  • hi spikeyxxx

    thanks a lot for your answer but  it still doesn’t work !!...

    • crew

      This should be working!!

      In the mapping node, set the Y rotation to 90.

      Try going back a step, delete these nodes, mapping and gradient, and add them again.

      Can you share the file on google drive or dropbox, if it's still not working.

    • dens if you look carefully, you can see that the right side of your column(s) is not black, but dark grey, which makes me think that your Object Scale is maybe also off; try CTRL+A (in Object Mode) to Apply the Scale.

    • hi spikeyxxx and everybody

      I continued with the alternative version, but as I wanted to understand I did indeed check the scale of my column and bingo you were still right spikeyxxx, so I tried to apply the scale on the object but, an error message is displayed: " cannot apply to a multi user "column_000_014""meshcube002 aborting;

      I come back to you all ( community ) to know how to solve this problem ( even if I continue with the alternative method which is excellent and allows me not to cut the flow of learning ) 

      so I tried to ctrl j on the column to create only one object but I got the error message: no mesh data to join .

      I probably forgot an important step when creating the column! So if you can enlighten me about my mistakes it would still be genial


      so thanks a lot at all and spikeyxxx the boss of the really good tips and tricks !

      take care of you folks ! see ya ..... peace




    • crew

      It gives the error because of the linked data properties with multiple objects.

      To solve this, select one column and go to the object data properties and click the number next to the object name,

      Your number will be different than this example.

      Now you can apply the scale to the column selected. You will need to do this for each column, Next select all your columns, and press CTRL + L , make links, and select object data.

      The only mistake you made was not to apply the scale before duplicating the column, but believe me your not the only one.

    • hi Adrien,

      thank you very much for your quick answer, when I click on the number of the object this one assigns a new number without however duplicated it is this ? 

      ....


    • crew

      Yes, it is renaming the data name not the object name, notice in the outliner panel nothing has changed. 

    • crew

      You can rename the data again after if you wish ( remove the numbers )

    • dens and adrian2301 there is a faster way. Select all columns and then:

      After that you can CTRL+A > Apply the Scale for all columns at once and then you can CTRL+L > Link Object Data.

    • crew

      Of course there is, one of those useful things buried deep in the menus. 🤣

      Thanks spikeyxxx 

    • Thanks for that tip, spikeyxxx 😀! I definitively need to be more careful of "Relations" 😉!

  • and the other solution works but the white and black are reversed!


    thanks by advance for your help !...

    • crew

      You can change the value in the bottom slot of the greater than node, or change to less than to swap the white and black.

      If you are following the tutorial the white should be at the top.

    • crew

      I'm just learning we can put non-bsdfs sockets (green sockets) into surface output? 🤔

    • theluthier this feature has been around for a while now; Blender inserts an Emission Shader in between in the background when you do this.

      It's great, I think and I use it all the time :)

    • It's similiar to connecting a yellow socket to a grey socket (which I would never ever do, I swear 🤞😉😁!) so that Blender does the necessary calculations under the hood. You only need to know what Blender is doing behind the scenes and be sure that you're using a version that supports this functionality. I nevertheless would add an "Emission Shader" in the case mentioned above just for a visually better understandable node tree. 

    • duerer connecting a yellow socket to  a grey one is completely different! (Sorry)

      With a yellow socket into a grey socket, the color is being converted to its Luminance, in OSL specification:

      float luminance (color rgb)
      Returns the linear luminance of the color rgb, which is implemented per the ITU-R standard as 0.2126R + 0.7152G + 0.0722B.

      which is the same thing that happens when using a Converter > RGB to BW Node...so maybe you are right and it is similar ;)

    • spikeyxxx Connecting grey to green sockets: I would never ever had expected you doing such things 😉😁! But fortunately the Blender Foundation doesn't notice that. Or do they 🤔?