glowgun

4 answers · asked · Lesson: Modeling the Launch Pad · Course: Build and Animate a Low Poly Rocket in Blender 2.8 for Beginners

every time I extrude and scale with it it comes off at an angle, is there any way to fix this?

every time I extrude and scale with it it comes off at an angle, is there any way to fix this?

  • Without seeing a screenshot of what you mean I can only take a guess.

    E to extrude plus immediately pressing S to scale should work as long as your transform pivot point has not changed. So the first thing I can think of is to ensure your pivot point is set correctly.

    By default it should be set to "Median Point" which is also how it's set in this part of the tutorial. The image below will show what to look for.



    I hope this helps and if it doesn't please post a screenshot! If you've sorted out what had gone wonky please let us know so future students who might run into the same problem will see your solution. ^_^

    • Everything seems to be oriented around the 3D cursor and when I tried changing the transform pivot point as you'd shown it made it no longer able to be rotated or scaled.

      The transform pivot point was set to "3D Cursor" and I have no idea how it got like that but even after changing it I can't seem to fix it.

      Thank you for your help though, much appreciated

      In this image I have the crater selected, but it can only be rotated or scaled according to the 3D cursor

    • In the image you posted the transform pivot point is definitely set to the 3D cursor. It's possible that in a previous lesson he had you change it for some reason. Sorry, I haven't done that tutorial but possibly he had you copy and rotate the fins around the 3D cursor? At any rate, the transform pivot point is definitely off somehow.

      If you chose "Median Point" from the dropdown and it disabled rotating and scaling I'm not sure what the issue could be. I'd have to look at the actual blend file if you want to share it.

    • coyohti is correct. The pivot point needs to be set to median point via the drop down as previously mentioned. When extruding and scaling to restrict the transform to a designated axis, such as Z (up and down) after pressing E or S press the Z (or X or Y which ever you need) key to restrict to that axis and the extrude or scale will only transform along the selected axis. Quite often when scaling you may want to scale in two axis but not the third, for example if you want to scale in X and Y but not Z, press SHIFT+Z to exclude Z from scaling.

      This is dependent on the transformation orientation as defined next to the pivot point, by default set to global. There is a lot more I could explain, like press Z twice for Local axis, but a good way to learn is to try out different pivot points and orientations and see what happens, you can always CTRL+Z to undo.

      🍪Eat cookies and carry on🍪