livia

7 answers · asked · Lesson: Brush Textures · Course: Fundamentals of Digital Sculpting with Blender

brush texture doesn't work

I am working in 2.91 version and when I try to use brush with uploaded image similar to the tutorial, it does not work, i.e. I see no texture just the regular draw on the surface. Could you help me figure out the issue?

  • llivia Is your mesh sufficiently subdivided (manually ("CTRL + E" => "D") or using a "Multires Modifier")?

  • Yes, I double checked and added more subdivisions using multires modifier, yet using the snake hook from sculpt mode, I cannot extend the tentacles from the sphere :( I at best get some spikes that look like this image:

    • For "Brushes" like "Snake Hook" you need "Dyntopo" instead of the "Multires Modifier" because "Dyntopo" creates new geometry (after triangulating the whole mesh as soon as you turn "Dyntopo" on) under the "Brush" whereas the "Multires Modifier" uniformely subdivides the mesh once creating an all-quad-mesh. Since you can't use "Dyntopo" and the "Multires Modifier" at the same time, delete the "Multires Modifier" and check the "Dyntopo" box:

      You have to confirm the "Warning" that switching "Dyntopo" on will delete all "Vertex Colors", "UV Maps" and other "Custom Data" in order to finally activate "Dyntopo":

      Please note that you have to reactivate "Dyntopo" each time you come back to the "Sculpt Mode" (for example after switching to  "Edit Mode")

      "Dyntopo" automatically subdivides the mesh into "Triangles" as already mentioned above:

      The "Dyntopo" is per default set to "Relative Detail" with a "Resolution" of "12 Pixels (Px)" and "Subdivide Collapse" as "Refine Method" which means that the mesh under your brush is subdivided so that the smallest faces will cover an area of "12 Pixels" diameter and all shorter edges will be removed. So, the "Relative Detail" depends on your distance to the mesh. For finer details, zoom in, for a more coarse subdivision zoom out. With the default settings and the brush shown above, you get this:

      Setting the "Relative Detail" size to "1 Pixel (Px)" creates a more detailed mesh under the brush:

      If you don't want this "Distant Dependant Resolution", choose "Constant Detail". The "Resolution" value is a "Divisor of Blender Unit" so that higher values subdivide your mesh more  giving you additional geometry to work with:

      Lower left corner with "Constant Detail Resolution" set to "3" (default) and upper right corner with value "12".

    • Thank you so much! that fixed it :)

    • llivia That's good news 😀!

    • crew

      Thanks for helping a fellow Blender comrade duerer 🤝

    • theluthier Anytime 😀!