Benjamin Lee (relidin)

14 answers · asked · Lesson: Modeling a Low Poly Room · Course: Fundamentals of 3D Mesh Modeling in Blender

How to improve Cycles preview speed?

With this low poly scene and my 1080ti graphic card Cycles is still too slow to generate a clear preview.  It's really painful to make material adjustments in this situation. 

So what is the correct procedure? Should I tweak everything in Eevee first then render the scene by Cycles? Or are there some mysterious options I don't know which can magically make Cycles preview faster? Thank you.

Or as: how can I use Cycles with a preview quality similar to Eevee?

  • You can use Eevee. 

    When using 2.9, you can also try the Viewport Denoising options with Cycles:

    • Thanks for replying

      I tried Blender 2.90.1 with Cycles viewport denoising (by checking Denoising -> Viewport) on my low-poly room scene and Blender crashed. I love using Eevee so it would be great if I can ignore Cycles for all my following projects. 

    • Well, you don't have to use Cycles if you don't want to...

      I myself avoid using Eevee, it's mostly a preference. Speed vs photo-realism and a low-poly room doesn't need to be photo-realistic I think ;)

    • I learn Blender mainly for game asset creation and game CG so my goal is to produce decent looking renders as fast as possible. In this case, I would prefer Eevee or even viewport rendering to Cycles.

      I know many people learn Blender to create avenger-like stuff, yes they are tough.  Just to me photo realism was never my goal :)

  • Your card seems like a pretty decent one. If you can use EVEEE go for it. It might lack some features like glass-like materials, displacements/bumps via shaders etc.

    My suggestion is to use a low sample count & use a denoizer. Also use the Auto Tiles plugin.

    I got pretty good results even without an external GPU.

    • Thank you for the suggestion. 

      I made a very simple scene and lowered Cycles viewport samples to 8, it's still not as fast as Eevee. And for a dark scene, low sample count creates a horrible preview which I can barely see the details.

      I can't access Youtube for now so I assume it's Auto Tile Size addon. Don't see a huge improvement yet, may be it's because my scene has few objects.

      I think like Jonathan said below, when using Cycles,  I'd better use material preview mode to adjust color & normal map, and use render preview only to adjust light. Currently Cycles viewport denoising in Blender 2.90.1 may have a bug that cause Blender to crash,  I will definitely check if it works when it's available.

      Also I thought having a 1080 will make Cycles blazing fast, sigh....

    • Recently, Blender started to take advantage of RTX cards. Using Tensor cores to do the denoising (AKA: Optix).
      I have a RTX 2060 and it's quite good.

      You can check the performance data here: https://opendata.blender.org/

      P.S. Existing RTX 2000 series cards will be cheap or will get discounts as 3000 series available on the market. 

  • crew

    I'm also using a 1080ti while recording, so I'm guessing it's probably the same speed for you as it is for me. Here's what I do to tweak materials:

    • Use the material preview mode (Eevee) instead of rendered mode if making simple adjustments like color
    • Use Ctrl+B to focus on smaller areas at a time instead of sampling the entire viewport 
    • Use "/" on the number pad to enter local view for the object I'm working on 
    • Thank you for the advice. 

      One more thing, I think there's something wrong with Cycles viewport denoising:

      1. open Blender 2.90.1 with default scene (cube + camera + point lamp)

      2. Properties -> Render Properties -> Switch Render Engine to Cycles

      3. In Sampling, check Denoising -> Viewport

      4. In 3D Viewport, change Viewport Shading to Rendered

      5. Blender crash

      Wonder if this is a bug of Blender 2.90.1. jlampel spikeyxxx 

    • Looks like the option you choosed for Denoising is not supported.

      * Try to check that you selected "GPU Compute"

      * Maybe stay out of Optix denosing

    • Wonder if this is a bug of Blender 2.90.1

      No, I think not:

      Are your drivers up to date?

    • crew

      If you get a crash on an official build, it's definitely worth reporting it as a bug. I haven't experienced it, but it may be hardware specific. 

    • Thank you for your time. aarunoda spikeyxxx jlampel 

      After searching for Optix and RTX, I thought I may have to throw my GTX 1080Ti into a trash can, here is what I've found:

       1. Blender Preferences -> System -> Cycles Render Devices -> OptiX -> GeForce GTX 1080Ti was not automatically checked by Blender 2.90.1

      2. If this is not checked,  enabling viewport denoising will crash Blender by setting Cycles Render Properties -> Device to CPU or GPU Compute.

      3. If this is checked, enabling viewport denoising will crash Blender by setting Cycles Render Properties -> Device to CPU. (spikeyxxx's settings crushed too, may be he has a RTX GPU?)


      Somehow, I've got Cycles viewport denoising working on Blender 2.90.1 + GTX 1080Ti by 

      1. Make sure  OptiX -> GeForce GTX 1080Ti is checked

      2. Set Cycles Render Properties -> Device to GPU Compute


      Cycles viewport denoising is FANTASTIC!

      Hope this may help people who are facing the same problem.


    • Glad you've got it working!

      may be he has a RTX GPU?

      I would like to be so lucky, but my GPU is so old that I can't even use it for rendering. (GT630)