Ingmar Franz (duerer)

21 answers · asked @ video mark 16:49 · Lesson: Grooming Body Feathers III · Course: Short Film Character Production

Piero: Cycles Hair Shape Settings in Blender 2.90

In Blender 2.90, you can find the "Cycles Hair Shape Settings"  in the "Hair Shape Panel" of the "Particle Properties Tab" of the "Properties Editor" ...

... as well as in the "Hair Panel of the "Render Properties Tab" of the "Properties Editor" where you can now choose between "Rounded Ribbons" and "3D Curve":

"Rounded Ribbons" offers you a setting for "Steps" whereas "3D Curves" automatically tries to smoothe it as much as possible.



  • You've been immensely helpful as I've been working my way through this course, Duerer! Thank you so much! I'm having a problem I'm wondering if you might be able to solve. My particle systems are rendering with black "strings" attached to every instance of the object (feathers) and hair particles. You can see it particularly in the hair system and at the edges of the feathers. Any idea what this is from and how to solve it? The images show the materials I'm using for the hair system and feather system as well as the particle settings. I've circled some of the dark areas, which are the "strings." I'm also including images of the model in solid and material preview modes. Any ideas? Thanks in advance!

    • bbkol Are you in EEVEE? Maybe it's from the "Shadow" settings. Does it look the same in Cycles as in your screenshots?

    • The first two images are cycles, the fourth is EEVEE.

    • Maybe, there's an issue with "Subsurface Scattering" as described here.

    • Ah, yes, I'd seen that thread before, and then forgotten. I removed subsurface scattering from the hair texture, but I also had to uncheck "From instancer" in the texture coordinate node. So that's only required for particle hair systems that are using objects rather than just the hair strands? Anyway, it's solved for the hair strands, thank you! I'm still having problems with the feather objects, but I'm now pretty sure it has nothing to do with the instancer, but with the feather textures or mesh. The dark lines appear where the mesh intersects with other objects, as you can see in the image I'm attaching. It's only visible in cycles. 

    • So, apparently, this has been a problem in cycles for years, where a transparent object has a black line where it intersects with another object. Doesn't look like they'll be fixing it very soon. Someone on the first thread suggested trying to mask part of the mesh with vertex groups, but I tried, and if you mask even one vertex of the feather mesh, the whole thing disappears. So, I'm not sure what do do. If anyone has any suggestions, I'd love to hear them!

      https://bit.ly/2O36GjT

      https://developer.blender.org/T85840

    • bbkol could you provide us with a link to your .blend file? (Use Dropbox, Google Drive, or any filesharing service). Please include all images:

      I can hardly see any lines at the intersection, just vey faint and only when zoomed in really far; nothing like what we see in your case:

      You can probably not even see it here (try downloading the screenshot and zoom in...)

      From further away:


    • bbkol The "From Instancer" box must be checked only if you use the hairs for duplicating objects and it works only with Cycles. Hair strands alone automatically pick the color from the lacation where they are growing. The black lines in the example file here also appear when using a "Transparent BSDF Node" instead of the "Principled Node"  if the angle between the transparent plane and the intransparent cube of that file is very small:

    • I'v just seen that the camera in the example file here has an extreme focal length of 400 mm and is very close to the object:

      Lowering the "Clipping End" value of that camera makes the intersection line appear grey instead of black:

    • I just tried lowering it, but it had no effect :-(

    • These black lines at the intersections of transparent objects with other objects seem to be a problem of Cycles since when I switch to EEVEE and set the "Blend Mode" for the transparent object to "Alpha Hashed", these lines disappear:

      But EEVEE can't be used for inheriting colors from the instancing object. So it's not an option for the bird's feathers.


    • Yes, definitely a problem with cycles!

    • bbkol I really don't think the intersections are what's causing those lines in your case!

      A plane would intersect differently:

      and your lines are way  too thick.

    • Interesting that this intersection line turns white when switching off "Cast Shadows" for the "Point Lamp" in the example file here:

    • Hmm, yeah, turning off shadows for the area lights in my file works a bit, too. The lines are still dark, but less noticeable. 

    • Setting the number of maximum bounces for "Transparency" from 8 to 20 helps reducing black areas:

      1) Before

      2) After

      "Transparency" is not affected by the "Max Bounces Total" setting!

    • I would have expected that turning off  the visibility of the transparent plane  for "Shadow Rays" in the example file here would make this line disappear but it unfortunately doesn't:

    • duerer Wow, yes, that helps a lot! Combined with turning off shadows, it looks MUCH better. Thank you!

    • Okay, you've already figured out that turning of Shadows (in both feathers and bird) helps.

      I've reduced it to the basics and gave the feathers a Transparent Shader and you were absolutely right bbkol that the lines are caused by the intersections.

      With Shadows off:

      compared to with Shadows on:

      Increasing the resolution and the filter size also makes it a little better, but seeing that this is for an animation, it's not worth the extra render times:

      I'd actually sooner opt for a lower resolution, which also improves it a bit (maybe in combination with a denoiser ?)

      Anyway, I've been trying things out and I didn't find a way to completely remove those artefacts, sorry.

    • I haven't tried rendering at a higher resolution yet, but I can bump it up considerably using e-cycles, and see what that does. I'm actually not going to animate it, as it's for a picture book, so higher resolution shouldn't be a problem. Thank you so much, spikeyxxx , between you and duerer, it's looking really good! Undoubtedly I'll have more questions before I'm finished, so most likely be hearing from me again.