techworker1 (techworker1)

3 replies · posted

Video tracking: fixing interruptions (best practice)

(I've looked at a lot of video tracking training and done a fair bit of it. But I haven't yet found a specific discussion of my issue, so here goes. It would seem to be a common one. Maybe someone can give me a pointer.)

I'm tracking a video with quite a lot of nice features. But a runner passes through the scene and the moving shadows briefly interrupt the automated tracking. (Tracked features are still quite visible to a human.)

It seems possible to fix this manually, but I'm not sure I'm doing it the best way. When the automated tracking stops, I can re-enable the track with the "eye" icon and manually re-position it. (The x/y curves in the graph editor are a helpful hint - make the curves smooth.) Then I can try to start tracking again from that point. Repeat the procedure until smooth curves are obtained all the way through. I see individual keyframes appear in the dope sheet for manual adjustments, but I guess they are equivalent to the automatic ones.

This is a little tedious, but could be worse. I've tried several uglier workarounds. Tweaking of tracker settings would seem to be limited.

Thanks in advance.

  • Additional discovery: "Fixed" tracks all move perfectly, but camera solver does not treat the fixes correctly and generates garbage. I guess I must render the video again with visible targets attached to the tracks.

  • Discovery #2. Performing a "lab test" with a very simple generated video, 12 clear features. (I probably could attach.)

    Tracking all the way through the footage, 5 tracks stop part way through. Of course "Solve Camera" fails, because there aren't 8 tracks on first and last frame.

    I manually adjust the failing tracks at the interruption points. Playing the clip shows all tracks moving correctly.

    "Solve Camera" again gives console errors ("No camera for <every-single-frame>"). This is odd, since the camera hasn't moved or changed since the first solve attempt. "Track" => "Clear Solution" and retrying does not help. Exiting and restarting Blender doesn't help. Something must have been cached which I can't clear, or error messages are misleading.

    Same behavior on 2.83.3 and  2.81a which I was originally using.

  • For fun, tried the exact same thing from scratch with 2.79b. With that version, after tracks "manually fixed", Solve Camera gives a track error of 127.xx and the camera motion is trashed. But it does the solve every time.