Declan Flynn (jdeclanflynn)

12 replies · posted

Shade Smooth weird looking?

So, here's a quick question. Today I added a cylinder mesh and clicked on Shade Smooth and noticed that it looked really weird. I did a little research and noticed that the box for "auto smooth" in the Object Data Properties area was unchecked. I don't recall unchecking this box, but I must have because I've never seen a mesh look so strange when selecting Shade Smooth. It almost looked like some of my older polygonal modeling gone terribly wrong. After checking the "auto smooth" button everything look normal.

My question is 1) is the cylinder mesh supposed to look that strange when Shade Smooth is checked? 2) Should the auto smooth button be checked by default, and 3) what does the "angle" option mean?

Thanks!

  • Sorry, the picture I attached is not loading... so here it is. This is what I saw before and after...

  • Hi Declan!

    Those pictures are the normal beavior. Autosmooth is not checked by default and shouldn't be, because it is very computational heavy. and you don't always need it (try a subdivided Suzanne, for instance..)

    The Angle is the 'border' between Smooth and flat shading. Flat shading considers the actual geometry, while smooth shading 'averages out' the Vertex Normals.

    No smoothing:

    Some smoothing:

    Smoothing every angle up to 90.1° (which int this case is everything:

    Jonathan Lampel explains this very well here: https://cgcookie.com/course/fundamentals-of-3d-mesh-modeling-in-blender

    Especially in: 'Smooth, Flat and Custom Normals.'


  • Spikeyxxx, thanks for that explanation. Unfortunately, a knowledge gap still exists. The link you provided is actually the class I am taking right now, so I'll look for Jonathan's explanation. Thanks very much!

  • Yeah spikeyxxx hit the nail on the head. The autosmooth is off by default.

    Great question though. I think it was well thought out.

  • I just watched that section of Jonathan's course. I still don't understand completely why the Smooth Shade makes the object look so strange within the viewport. I thought perhaps it was just a viewport thing, but it renders like that, too. So, that's a bit disconcerting actually. I will though leave that unchecked. Blender unchecks it by default even after saving and restarting, so that's a good thing. I feared that I messed around with something that I shouldn't have, so that tells me I still have  more learning to do when it comes to better understanding the nomenclature of a mesh object aside from vertices, edges and faces... 

    Thanks all!

    • Don't worry if you don't understand something completely; 3D modelling is very hard and there is really a lot to learn and I think there will always be some things you don't get in a beginner's course that tries to cover all the basics.

      Just re-watch this course in a year or so and you will be able to understand most, if not everything. Also, you are likely to forget some of the things that are not clear to you now and that way you will be reminded of those.

      To be honest, I have used Blender for about 8 years without understanding Autosmooth (if something looked strange when shaded smooth I just turned on Autosmooth and maybe changed the Angle if necessary) or Custom Normals and only learned what happens when this course came out....

      You already have an advantage over me there;)

    • "To be honest, I have used Blender for about 8 years without understanding Autosmooth..."

      That was the MOST helpful thing right there! Now I feel better. LOL! Thanks for that. I can relate. I've been using, professionally, Adobe Photoshop since version 2.0 and I still only use 10% of what that software offers, so yes, I can relate! 

    • I agree with Spikey. It is like concepts of photoshop and other programs but you add more dimensions and complexity for how light interacts. It can be A LOT to take in. I do the same thing as spikeyxxx I turn on smooth shading when I want something to look smooth and if the normals aren't doing what I want then I play with the autosmooth, but when I am modeling I rarely come across that since I am doing more complex objects that a capped cylinder.

      I really don't think about it as much as I should haha.

  • crew

    I still don't understand completely why the Smooth Shade makes the object look so strange within the viewport. I thought perhaps it was just a viewport thing, but it renders like that, too. So, that's a bit disconcerting actually.  

    It looks strange because it's averaging between faces that are at pretty extreme angles from each other. 

    For example, imagine what the flat shading would look like on the bottom of the cylinder. Then, imagine a gradient between the middle of the bottom face and the middle of a face on the front. That's what smooth shading is doing! 

    It looks strange because adjacent faces are very large (big gradient) and are at extreme angles (lots of contrast). 

    Because it blends with the adjacent faces, you can also sharpen up the result by adding more edge loops and thus decreasing the size of the extreme gradients.

    • And Jonathon takes it for the win! Yeah that is why my cylinders always look good I just didn't have the means or knowledge the he does to explain it well. I always inset my end caps on my cylinders probably for that reason alone haha. I just do it subconsciously without his nice explanation in the back of my mind.

    • Thank you, Jonathan for your illustration, which filled that gap. I now understand the 'why' to the question, "why does it look so strange?" What  a huge help that was. Thanks to all of you for jumping on this question. It's been a great help! I finally get it!!! 

      (happy dance)

    • You know, it just occurred to me as I was making a few notes from what Jonathan added... Why would I want to make a cube or a cylinder appear smooth? I mean, a cube is flat on 6 sides after all. So, if I wanted it to look smooth, I could just bevel the edges, which is the same as adding edge loops to "smooth" out the gradients that appear when I Shade Smooth the cube mesh object. The same goes for a cylinder. The top and bottom are supposed to appear flat unless you de-cap it or get rid of the Ngon, and the cylindrical side is already relatively smooth looking, depending on the amount of vertices I add or take away... It just sort of occurred to me. Man did I over think that!!!!

      PS> Forgive my terms. I am still learning 3D and Blender's vast word lexicon.