Regarding Rendering Rocket - Still Flickering

I have included the World Environment and the Ground Plane, but I am still getting light flickering in my render. Does anyone have suggestions to fix this?

  • I haven't taken this course, but I was curious as to what you mean, so I checked out this lesson and the teacher 'explains' the cause of the flickering so: 

    'If we play this animation, you'll notice that the background flickers. This is because we are in orthographic view, which means we're basically sampling one pixel per frame [WHAT!!!???] and it's sampling random pixels from around this area, as we rotate.'

    I do not know what this means, but adding a large enough ground plane does work to avoid the flickering, so, maybe your ground plane isn't large enough????

    Or maybe you could upload your .blend file to any cloud service (Dropbox, Google Drive,.....) and paste a link to that file here, so we could have a look...

  • That flickering seems to be EEVEE-specific since Grant switches to CYCLES at 7:42 in his video. But I'm not very familiar with EEVEE and sampling one pixel per frame sounds really strange.

    • duerer Some testing proves that this flickering also appears in Cycles, but only with an Orthographic Camera,,,

      What is one pixel per frame? Does he mean one random pixel from the light source (HDRI) ???

      Maybe jlampel can help us out here?

    • I've created an example file with a camera rotating around a cube (250 frames for one rotation but clipped to 249 frames for a smooth loop animation). The background is a green-red checker pattern and EEVEE is the render engine:

       When I now switch - while in camera view and render preview mode - from perspective view to orthographic view, the green-red pattern is replaced by a uniforemely yellow background which is a mixture of green and red:

       Now I play the animation and get a flickering with red, green and yellow. 

      After having stopped the animation, I set in the "Render" tab in the "Sampling" panel "Viewport" from 16 to 1 and get a red background at frame 1, a green background from frame 2 to 8, red again from 9 to 17, green from 18 to 46 ...

      File is here.

    • Great! Thanks duerer 

      Now I understand what Grant meant.

      This also happens with Cycles btw.

    • So now I kinda understand how the flickering happens in EEVEE, but is my issue truly in my graphics card? I am currently looking to upgrade in the near future. I currently have an NVIDIA 1060 3 GB. Would this problem go away after getting a new system or upgrading?

    • Maybe it's just your driver...is it up to date?

      You could also test rendering with Cycles on your CPU, see if that makes a difference change your settings to something like this:

      Or even better (read: faster), do not render your Ground Plane at all and set the Film to Transparent:

      Then you can later add the Background in Compositing (we can walk you through how to do that. It's not difficult.), can't have background flickering if there is no background, right?

      Still a good idea to try it with Ground Plane for a few frames at least to see if your GPU is causing this somehow...

    • So, after troubleshooting for a while, listening to all accounts of wisdom and experience from everyone here - I realised the issue was the Specular property for my shading on the ground plane. After changing the Specular down to 0.038, and the Sheen to 0.5 to keeep more of the color's light, I got rid of the light reflection.

      Edit: And I updated my GPU Driver

  • Rocket - Blender File


    Here is the project file I have been working with. I have attempted to make some adjustments,but have reset it to where I haad the issue when I posted earlier. (Still  having same issue, but I think I made some headway by using another HDRI)