The collision physics are not rendering. The smoke is just going through the floor but when I play it back in the viewport render it looks correct. What am I doing wrong?

The collision physics are not rendering.  The smoke is just going through the floor but when I play it back in  the viewport render it looks correct. What am I doing wrong?

  • Did you maybe check "High Resolution" in the  "Smoke" panel of the "Physics" tab of your smoke domain (see bottom right corner in the image below)?

    This "High Resolution" effect is a kind of displacement done after the physics calculations have been finished and therefore doesn't respect any collision objects

  • Oh  I didn't use any smoke physics in the render. The smoke is actually just particles. I figured it out though, I had to bake it first lol the tutorial didn't mention it. Thanks for your reply though!

    • Yes, indeed, tweaking the settings for the particles can lead to outdated data in the particles cache. Refreshing the cache by changing for example the cache step number and then resetting that  number to the old vaulue (mostly step size "1") should solve this problem, too. Baking the particle simulation nevertheless should always be done before the final rendering it in order to have all physics simulations in your scene up to date.