connere

3 answers · asked · Lesson: Modeling Wood Details · Course: Modeling, Texturing and Shading a Treasure Chest in Blender 2.8

Bevel not appearing on the outside of my chest.

My bevels are not showing on the outside of my treasure chest box. They seem to be appearing on the inside edges and the lid is just fine. Checked my normals and they are fine. Thanks in advance.

Hopefully the blend file will help:

https://drive.google.com/file/d/1XykdI4jdbTUtl8fD1cJQGJOUhbRAz9Rf/view?usp=sharing



EDIT:

So, it seems like the bevel appears on all edges during edit mode, but then when I switch to object mode, you can see some are missing. I feel like I'm missing something really silly haha.

  • crew

    I checked your file and everything seems to be beveling as expected for me...Could you possible screenshot a before and after image of the issue you're experiencing?

  • I had the same issue but with the sides of the top of the chest. For anybody doing this now, the bevels appeared in the inside, so the easiest solution I could find was just rotating those pieces 180 degrees on the Z Axis. Instant "fix", at least appearance wise.

    • iiii1brain that would mean that your Normals were flipped (before your fix). The easiest way to solve this is by using the hotkey SHIFT+N in Edit Mode, with everything selected. Remember this key combo, because you will be needing it a lot!

      A simple way to see if you have a problem with your Normals, is to (temporarily) enable Face Orientation in the Overlays dropdown"

      The outside of the box should be blue (front of the faces) and the inside red (backside of the faces).

      SHIFT+N fixes all the Normals (of the selected Faces) at once (in more than 99% of all cases).