Shawn Blanch (blanchsb)

16 answers · asked @ video mark 2:38 · Lesson: Layouts and Workspaces · Course: Moving from Blender 2.7 to 2.8

Customizing Workspace Data - You’ve Struck Gold! Vid time 2:39

So this has been something that I saw when I first watched this series and I thought to myself “huh!?, interesting.....” and shelved it into long term foggy memory.


Well today I reloaded factory settings because my blender add-ons are over whelming my keyboard shortcuts and as I was setting up my workspaces I wanted to know how to customize the data that they had and I remembered something about it........somewhere 

I went to google to try and find other info and even went to the blender manual.......no luck. Then I remembered the 2.8 series you did. It’s like these 5 minutes golden minutes I wished I had retained 100% yet I only retained 1%

Holy crap. Workspaces with custom add-ons enabled is Genius! I’m sure the Python API stuff will come in handy for me one day. But today your video totally made my full year membership worth every penny. Thanks jlampel  How did you even learn this in the first place?!? I don’t see it in the manual and google was no help.

  • crew

    Yay!! Frankly I have no idea where I first saw that, but  I'm glad it helped :) 

  • So......now I have a question: I turned on the filters and it doesn’t seems to filter out keymaps for meshmachine : alt + z for example should toggle x-ray and in mesh machine it turns on the symmetrize.  I turned on filters for the add-on section and made sure those are unchecked but the keymaps are still to mesh machine. Am I missing something?

  • It works for HardOps, which uses Q:

    (Pablo Vazquez showed this on Blender Today, when this was added...)

    • Yeah, for some reason the Machine3Tools did not make it onto that “Filter” list on my blender which was why it wasn’t turning off the keyboard shortcuts.


      why do some add-ons not make it onto the list and is there a way to add them manually???

    • Well I've never used Machin3Tools, but I just installed it and it appears on my Filter list as soon as I enable ther Addon:

    • Hmmmm. Maybe I need a clean install of Blender .


      When I upgraded to 2.82 I think I got some versions intermingled for the add-ons somehow. Too long of a story to share. Must be why it doesn’t show up. I’ll check the add-ons folder for 2.82 and see if that fixes it.

      Thanks for troubleshooting with me spikeyxxx 

    • Well in Blender Addons are version specific, so yes, maybe that causes some problems...

    • crew

      Interesting! I suppose you could try a clean install. Disabling Mesh Machine in that panel removes it from my context menus like it should: 

  • Long story short. I did a clean install. And I missed that the 2.82a release was out, so it was a slight upgrade anyway, huzzah.


    I forgot to test because I did a complete clean install and spend the next hour adding in all of my add-ons before getting off to be with the family.

    I’ll report back. I’m sure that fixed it though.

    • So it was fixed........I had the same functionality that y’all had until it came back at some point while I was playing with Blender.

      Layer Painter and Machine3 are still active for some reason.......

      Not sure if this is a 👾 with Blender or with an Add-On or Both. I'll investigate further


    • MeshMachine and Machine Tools are still taking over my keyboard shortcuts even with filters turned on.......


      Kind of an annoyance and not a game changer. I show how I can change from vertex mode without the tools turned on, but when they turn on AND are filtered out, it still does not filter them.......until I deactivate the add-on again

      Is there a way to correct this or is it a Blender Bug?

    • I emailed MACHIN3 to see if he has anything to say about what is going on.

    • Those are third party addons, so I don't think it's a Blender bug...

      I don't even see Machin3Tools in my N-Panel:

    • This was my response in the email I sent over on Blender Market.

      Hi Shawn, 

      workspace filters don't seem to fully filter out everything. Especially not addon set keymaps, but also other things. It's a known issue, see  https://developer.blender.org/T62567

      -MACHIN3


      Looks like Workspace Filters and Keymaps are not entirely straightened out......? Hard to tell from the thread. Doesn't look like the dev's have replied much as the last statement asks about it being a bug or not.

      I can confirm though that this isn't working the way I thought it was supposed to. I am watching Pablo's Blender Today#81 in hopes he explains it in this video (based on my google search results haha)

    • Hey Shawn, thanks for the link!

      As far as I understand, this is indeed a mistake of the addon developers:

      : Brendon Murphy (meta-androcto). wrote:

      the issue was in the submodule registration.
      Basically, the workspace filter filters active addons but not the addon's submodules if they are not correctly enabled/activated and most important, registered..[....} Register your addons and submodules properly and workspace filtering works.
       Thanks.

    • Man I must have missed that or it was late and I was tired.  Thanks spikeyxxx
      I sent that over to MACHIN3 to see if he could figure out a solutionfor the add-ons I am having issues with.

      So, I am not sure this is perhaps a bug but I don't think Blender did the dev's any favors. Is there a place where it explains the process required to register Add-Ons and Modules I wonder?

      I'm just thinking out loud.