adrian2020

12 answers · asked · LiveStream: Shading, Lighting, and Rendering an Underwater Shark Scene with Eevee

rendering problem with the cube volume

hi, the insert image function does not work hier. 

in my layered works pace my scene looks finishend but in the rendered work space it seems that the cube volume with all the effects do not work and do not appear in the rendered image.  

  • Hi adrian, hard to tell without a screenshot, but are you maybe in LookDev Mode? Then you need to enable Scene Lights. Rendered Mode should work out of the box:

    From left to right: LookDev with Scene Lights, LookDev without Scene Lights, Rendered View.

  • hi spikeyxxx,

    i get the first image as render instead of what i see in the second image (print screen) in the layout work space.


    Thanks for your quick answers.

  • Still just guessing here, did you, by any chance, make the vignette in the Compositor?

    Then it could be that you have the wrong thing connected to the Output > Compositing Node (not the Viewer Node).

    Although I can't really imagine how you would get this result...

    Could you post some screenshots of the whole Ui with Shader Editor open and as much info visible as possible;)

    (I can't remember how Kent did all this in the stream...have to re-watch that..)

  • crew

    aadrian2020 I'm not sure what's happening 🤔 Feel free to post a download link to your .blend file and I will take a look at it. Best way to do this is uploading to Dropbox, Google Drive, or equivalent service and copy + pasting the share link here.

  • hi spikeyxxx and kent,

    thanks for answering. i spent yesterday the hole day and  fallowed  your tutorial Kent. and it was really fun especially because i could fallow along and because 2 weeks ago i was learning how to navigate in blender and started to learn blender.   

    Hier is the mega link to my blend file : https://mega.nz/#!Wx1XBQoS!YHUyPG26JL3oS2kSP1szuuZmdnZwRDNEmTAwZ18PqwY

    I am really surprised with how helpful your team is and hope you kann find your way through my mess of nodes. i ll post here extra 2 screen shots - i think the problem is wit the volume object. if i change the option to anything else than wired than the scene looks like the render result that i posted yesterday.  but ...as i mentioned i am not an expert (not yet)

    thanks for taking the time to help me. there is no hurry. i can weit and enjoy the other tutorials on your site in the meantime.  

    • crew

      Thanks for sharing your .blend file. The issue is that your Surface input (of the Material Output node) needs to be blank when using a volume. The wire viewport display seems to ignore that part of the shader but the render doesn't. So simply unplugging that is the fix:

      PS: I'm glad you've enjoyed the tutorial! And also glad that you're finding our community helpful :)

      EDIT: I didn't reload the page till after I posted a (duplicate) answer. Spikey had you covered!

  • Hi Adrian, you have already figured it out by yourself!

    When you set the Viewport Display of the Cube to Textured or Solid, the Environment (light) can't enter the Volume (Cube), so from camera view you can only see what is inside the Cube (because the camera itself is inside the Cube).

    When actually rendered (with F12, not the Viewport Rendered View), This will be a problem, because then the Cube will also block out the Environment.

    What you will need to do is remove the connection between the Colorramp and the Surface of the Material Output (I don't know what that's doing there...), like so:

    That should fix it.

  • Hi Spikey and Kent,

    thanks for the help. !!! I just rendered successfully my scene!

    Awesome CG Cookie team ! 

    Now i just have to fix my other problem -- my day job getting in the way of my blender learning.  :P