jesse94

22 replies · posted

Mantaflow cache type replay/live preview wont work fo me follow up

This is a follow up post to my mantaflow cache type replay/ live preview not working for me. When it seemed like the cache type replay/live preview was working fine now I came across another problem at some point in the timeline the cache type replay/live preview will begin to float in the air and sick to the monkeys.

  • Try and delete your cache_fluid folder. Then try again. Play the animation starting from frame 1. With Replay, the cache is written according to the timeline, so first frame 1, then frame 2, etc.

    Do not look at what is happening at frame 173, before the simulation has reached that frame.

    • I deleted my cache folder and made a new cache folder in it's place and I selected the new cache folder in blender but it still didn't work the live preview is gone completely now.    

    • NO idea why it doesn't work for you.

      BTW the Mantaflow developer is here now: https://www.youtube.com/watch?v=jKBBgYZsfWE

      You can ask questions here:https://blender.community/c/today/sYdbbc/

    • The layout of the website is kind of confusion to me how do you ask a question?   

    • never mind I figured out the website now 

    • HI jesse, I know now what is happening.

      Mantaflow uses FLIP fluids. What you see is only the surface of the fluid. (The colors depict the speed of the water surface .)

      because the water keeps flowing in the Domain, the Cube is filling up with water and the surface of the water rises. Also around the monkeys the water is treated as a surface. That is what you see. If I remember correctly, CGGeek turned of the 'Use Inflow' at frame 41 or so. That is why his Domain didn't fill up completely and the water surface didn't rise up so high;)

    • thanks for letting me know

    • spikeyxxx  is a Great Fellow

    • I started a new blend file and I animated the inflow but that still didn't work. What am I missing?. Here’s the same link I replaced the old blend file and cache folder with the new ones I even added a video to show what happens on my side of the screen just in case it’s different on your side . https://drive.google.com/drive/folders/1A0zCrSXXVFM26l2wyijriq3486anbTap?usp=sharing

    • Well, that is mysterious! In your mp4 nothing is happening at all.....

      I opened your file, went to Frame 1. Changed the Liquid Sampling to 1 and then back to 2. (Simply change any setting and then change it back, to clear the cache.) Played the animation and everything worked as expected:

      All the way from frame 1 to 250, without any glitches or anything.

      So, honestly I have no idea what is wrong. (I'd like to know, though...)


    • did you deleted the cache folder and made a new one before you changed the setting and changed them back?

    • I didn't download your cache folder seperately, just opened your .blend file and cleared the cache like I mentioned above.


    • I played around with the  blend file some more.  When I delete the cache folder in the cache bar in blender and I run the simulation the live preview will show and the inflow will fall down to the ground but when you go back to frame 1 the live preview will still be there and the inflow will fill the domain again. 

    • Hey Jesse, in the cache bar is not the folder, but the path to the folder. Do not delete that.

      Either delete the folder itself on your hard drive (should be next to your .blend. Blender will create a new one when playing the simulation), or, easier, just clear its content by changing a value in your Domain settings and then changing it back to what it was.

    • I tried that still didn't work the live preview won't show up here's a video of whats happing on my screen  https://drive.google.com/drive/folders/1A0zCrSXXVFM26l2wyijriq3486anbTap?usp=sharing

    • Well Jesse, I am flabbergasted.

      You have some fluid there, but as soon as you accept the path to your cache folder it is gone.

      I cannot reproduce this, unfortunately.

      What happens when you try Modular or Final?

    • I have't tried modular or final yet but I well let you know if I have problems with those two  

    • I took a little break from mantaflow but now I came back to try modular and final still didn't work here's a video of whats happening on my screen https://drive.google.com/drive/folders/1A0zCrSXXVFM26l2wyijriq3486anbTap?usp=sharing

    • Hi Jesse, the only thing I can think of now, is that it's a (maybe operating system specific) bug. 

      I looked in the cache folder you uploaded and it doesn't have any Data in it, only a Config (should have both...)

      Try it one more time in today's build. Simplify the scene even more (just remove the monkey's, that shouldn't make any difference) and report it as a bug. (Go to Help > Report a Bug.)

      I've looked through the reported bugs already and couldn't find it there...

    • I'm on the developer page of the blender website but I don't understand how to report a manaflow bug and are there are different forums for official blender versions and alpha versions? 

    • I figured out where to report a bug  but I still don't understand all this stuff it saids in the description

      System Information**

      Operating system: Darwin-18.7.0-x86_64-i386-64bit 64 Bits

      Graphics card: NVIDIA GeForce GTX 660M OpenGL Engine NVIDIA Corporation 4.1 NVIDIA-12.0.24 355.11.10.50.10.103


      **Blender Version**

      Broken: version: 2.83 (sub 11), branch: master, commit date: 2020-03-26 23:49, hash: `rBf1fb3eb97540`

      Worked: (newest version of Blender that worked as expected)


      **Short description of error**

      [Please fill out a short description of the error here]


      **Exact steps for others to reproduce the error**

      [Please describe the exact steps needed to reproduce the issue]

      [Based on the default startup or an attached .blend file (as simple as possible)]