weird texture paint issue...

I finished the course and wanted to go back and do a high resolution tank (2048x2048), but I am having an issue that I didn't encounter my first time through: When painting the tank panels in texture paint mode the fill tool will work, but when I use the draw tool nothing comes up on the mesh. I tried with the stencil opacity on and off, and that didn't help. 


PS-sorry for all the questions...

  • Hi Thomas, don't worry about asking questions! The problem is probably that you have 4 Image Textures in your material (Shader Editor), but none of them is selected. Blender doesn't know which one to paint on.

  • Thanks for the response! I did check that, one of the textures in the editor is selected. The fill tool is working, but the draw tool isn't. When I go to my 720 model I can use the draw tool just fine. Is there something I have to do differently for a higher resolution model? Thanks

  • Hi Thomas, I am confused; in your screenshot you don't have 'Tank_Panels_1' selected in the Shader Editor, so I thought that was it. It is the active texture (see Texture Slots in your Tool Settings and the  UV Editor).

    As far as I can see, you are trying to paint on the 'Tank_Cannon', used the Fill Tool on the 'Tank_Base-Color_1' and switched your Texture to 'Tank_Panels_1' or something like that...I can't tell much more from the Screenshot.

    But it has absolutely nothing to do with the higher resolution.

    Could you send a link to your file? (use Dropbox or any Cloud service..) Make sure to go to File > External Data > Pack All into .blend, so that it includes your image textures.



    • https://www.dropbox.com/sh/obit0m5i5tqugtw/AAAXl-q9RRVXRdlqpOnNEL19a?dl=0

      I packed the file so hopefully this link works. Thanks again, I really do appreciate all of your insight!

      Yeah, I noticed I did not have it selected during that screen shot, but even when it is selected nothing is showing up in the draw tool. I read a post that mentioned something about disabling the "display texture paint UVs" but that didn't seem to have any affect either. I also checked the normals, and tried switching the mode from "material" to "draw."


    • Hi Thomas, I don't understand exactly what is happening, but, as I couldn't even paint on a Default Cube that I added, I knew that it was probably one or more of your paint settings and found this:

       Click the x, where the mouse pointer is to remove the black texture. (Must be working like some sort of mask, I guess...)

      Then you can paint away. (Hurray: a one-click-solution!)

      Let us know if you run into other issues (or if this doesn't work for you).

    • It worked!! Back to work-Thanks so much!