ndoell

5 answers · asked · Lesson: Sculpting Melvin · Course: Fundamentals of Digital Sculpting in Blender

How can I fix bad geometry inside the model

I have been trying to sculpt Melvin. The problem I have is that I get some weird geometry while sculpting  (see screenshot). I don't know why exactly this happens but I suppose I used the wrong mode for dynamic topology.  But in this case it started by inflating, so the space between the vertezies should have increased. But then weird artifacts started to appear. I tried to smooth them out but that didn't help either. I tried different modes of dynamic topology but it seems the problem is only getting worse. 

I also tried to remove the inside geometry in edit-mode. But then I get many small holes. Should I just cut out the whole section?

  • nndoell Is there more than object or "mesh island" in your sculpt mesh? I think you can select islands by highlighting a mesh and pressing "L" on the keyboard. If everything is highlighted then you only have 1 mesh.

    Maybe the best approach is to simplify the dynamic topology in that area, then cut out that part and close it back up.


    I think there is an option in dynotopology where the more zoomed out you are the less detail gets generated when you sculpt around a part of an object.

    I hope that helps.

  • Hi ndoell, inflating doesn't (necessarily) move vertices away from each other. It moves them along the Normals. This can cause a real mess, when surfaces start to get close together or even passing through one another. Smoothing will just make things worse.

    As you are using (at least ) 2.81, you can use the (Voxel) Remesher instead of Dynamic Topology (not both at the same time!).

    • Hey, thanks for the reply (also @Shawn Blanch). The Voxel-Remesh does the trick (it almost feels like cheating :D). Blender already prevents using dyn-topo and remesh at the same time. 

      I tested a little bit and I found out that it happens to me when I move my mouse to quickly. If I move the mouse very slowly, then I can inflate as much as I want. But is there a way to prevent this from happening ?

    • I don't know if there is a way to prevent this sort of thing, but I guess it's a matter of experience; the more you sculpt the better you get... (I am not very good at sculpting, so not the best person to ask.)

  • crew

    Sorry I'm late to this thread, but I would bet that you used the inflate brush to push *inward* with Subdivide edges mode. That consistently causes these kinds of artifacts in my experience. As a rule of thumb I only use Subdivide collapse when inflating inwardly. That method auto-generates new topology as you go and prevents the "collapsing in on itself" artifacts.

    Thanks to spikeyxxx and blanchsb for the help on this one!