Scott McClellan (pffsfs)

44 replies · posted

Polybook - Old Dog

Well... it's been a long inconsistent time for me hooking up with CGCookie and 3D anything. That's come to a close. Having gotten through hunting season here, I've made a drastic decision which should help spur along 3D learning, creativity and hopefully in time worthwhile posts. I've bit the bullet, and after 12 years, have closed down the motel for good - so no more disturbances and no more excuses to not move forward with this venture.

Goals... yup (some are doable and some are flitting pipe dreams). Hoping to get through an hour of tuts per day (learning flows or otherwise) and post assignments. I also have a number of projects that are running around in my mind. A couple are just fun little shorts. A couple are not so short, but should prove to be fun nonetheless. It's all fun, right? So right now, it's been penciling out scenes and assets, but thus I'm afraid I get ahead of myself. First, I NEED to learn this craft - hence why I shut the motel down and will be now concentrating solely on this. All I can say is thank god for CGCookie.

Let the learning begin...

p.s. still in 2.79 (NOW IN 2.80 !!)

  • pffsfs Welcome back Scott, I missed ya funny 2.79 comments Old Dog! 😛 Wow that's a huge step, closing your motel.. I wish you the best of luck with your learning, looking forward to seeing your progress!

    PS the Beta version of 2.8 is out now 😉

  • Welcome back!  Nice to see you again!  Looking forward to what you can do!

  • 4 Dec 2018

    Closing it out for the day. Thank you Miranda - I'm afraid with luck will go motivation. Thank you also Silent.

    Starting out with the Mesh Modeling Bootcamp. Will  probably go back over retopo of the orb and do a quick Melvin just to see what I've lost. Then it's off to the races (so to speak).Well... probably could have had this coffee cup thingy done and out of the way a while ago, but i decided to tackle a number of different styles. Only put a saucer under one of them. I almost feel as if I'm starting over. 

    This last one is a teaser... anyone want to venture a guess as to what this is??

    Enough coffee cups... Off to model with primitives (see what I mean by starting over. lol.)

    Until the morrow.

  • 5 Dec 2018

    drgnclw … Thank you. Starting always seems to be the hard part

    silentheart00 … Here’s to hoping. Just not wanting to get burned out. And yes, that last one is actually called a mustache mug - keeps the mustache from getting wet. Sorry yyukinoh1989 … it wasn’t a ‘bat signal’ lol.

    ssmurfmier1985 … not sure about the ‘in no time’ part, but I thank you. Doing what I can whithout burning out


    Not sure why I'm doing yet another primitive model, but I decided to play along and look a the snapping function, only to find out I could have saved myself some time had I planned ahead. Ugggg. planning sucks. 

    Here is the submission in Sketchfab (hopefully this works)

    • pffsfs Hey, at least you know about snapping now =]  And yeah, the link works.  Nice house.  Could use a ground plane, though, to help it not look like it's floating through space.  Otherwise, good work!

  • 5 Dec 2018 (reprise)

    silentheart00 ... thank you for the feedback on the floating house . hee hee

    Made it through a bit more today, even though got a late start. Not there was an exercise for it... voila - soccer ball. I figured it's best to commit some of these concepts to muscle memory. Ran into a snafu during the creation that I finally got figured out.

    Been having fun reading through ssmurfmier1985 Polybook and even learning there along the way. Hope to get to a few others' soon. I find it refreshing to see what others are doing, their work-arounds for problems and ideas as well. Gotta ove the CGCookie community.

    Alrighty peeps... it's pillow time. Happy modeling/animating and creating

  • When 2.8 is finished we'll all be beginners again :)

    • ben-reynolds I reallly isn't too bad, the differences aren't as extreme as most people think. You get used to it pretty quick and then you never want to go back! 😬

      pffsfs Glad you enjoyed my Polybook and found it useful! 😊 I agree about the CG Cookie community, they are the best 😎

  • 6 Dec 2018

    Well… redirecting topology seemingly got a bit easier (well it makes more sense now - it ain’t easier). One mistake I was making is using “F” to fill between vertices instead of “J”. Makes a HUGE difference. That’s why I like taking the time to actually DO what he’s talking about. It all seems easy enough listening to it, but until I’ve made my own mistakes in going through the same thing, I find I really haven’t ‘learned’ it. It’s satisfying and humbling at the same time.

    The CGCookie logo definitely had my brain freezing at times, but I just took Jonathan's basics and pushed my way through. Yikes... Just looked at the time (nearly midnight), but I finally got the logo done.

    It's also here if you want to spin it around. lol

    yyukinoh1989 ... had a chance to go through your Polybook today as well. Nice ideas going on there. The building is gonna be very interesting.

    ssmurfmier1985  ... 2.79 or death

    Night all.... zzzzzzzzzzzzzz

    • @pffsfs Nice work!  The iris is kind of poking through the bottom, but that's a small fixable thing.

    • pffsfs That whole course had a huge positive impact on my skills. By the time you're done with that course you'll have a solid idea on how to model pretty much any inanimate object.

      Keep pushing through!

  • 7 Dec 2018 (a day late)

    silentheart00  ...thank you. I knew I had gotten too exuberant with that depth and never went back and checked (the ‘devil in the details’… *sigh*)

    drgnclw  ...   Each step I take in that bootcamp certainly challenges me (or maybe I’m 3d challenged). In either case, I’m having fun with it and yes it’s definitely helping with honing the basics - always comes back to that. With the logo I kind of went off and saw what what came intuitively to me rather than following Jonathan “step for step” and yup I ran into problems. Most I was able to solve on my own going back to his preaching, but there was one at the end - had the exact same issue he was having - I had to go back to the video and see what he did. Now to try and remember that trick for later works....

    Speaking of challenging, the 'house' exercise is kicking my backside. Finally had to shut the computer off and say frak it. Deleted whar I did this morning and we'll start over and try again. After dong this seemingly easy concept that Jonathan laid out (I said seemingly - maybe it's just me), I'm going to take a little time and indulge myself in a house that I want to actually use in something (the ideas just won't quit).

    Here's to hoping the 8th is more productive. Ciao...

    • pffsfs don't get discouraged, 3D comes with a lot of challenges and everyone gets stuck at some point. If you find today is equally frustrating I would recommend getting away from this exercise for a couple of days (do something from another course or your own project) and then get back to it with fresh eyes. Often this helps tremendously! Keep at it and you'll get there 😊

  • 8 Dec 2018

    Thank you ssmurfmier1985 . It’s not so much discouraged as it is frustrated, but I get what you’re saying - often had to take that approach when programming. One day at a time and I’m an impatient one, so got to slow myself down and be realistic.

    What a difference a day makes. Lesson 1 - pay attention to the questions asked in the courses. There is always a good chance something that’s bothering you or you’re struggling with will have already come up. Also, don’t be afraid to ask questions as it will most likely help someone else down the road (if they bother looking at the questions).

    I hate tweaking. I hate tweaking. I hate tweaking. I hate tweaking. I hate tweaking. The only good coming out of tweaking is I’ve gotten pretty good at using snapping…. but…. I hate tweaking.

    9 Dec 2018

    Oh dear gawd… spent 2-3 hours trying to figure out why my bevel/inset wasn’t working and turned out to be a simple problem of logistics. Forgot when building the house every section was separate and as such the was a hidden wall in the way of the inset. (I hate tweaking).

    The house itself is FINALLY finished. Unfinished exercise here. Still have to complete the exercise by making it ‘homey’ - hoping to have that done this evening. But between last night and this morning fixing the hidden wall issue, grasshopper is in need of a break. Still planning on taking a one or two day sabbatical to work on a house I’d like to use as an asset. Hope y’all like it.

    By the way… did I mention “I hate tweaking”

    Two questions... where do you peeps find the emojis and second on long posts I don't seem to get a scroll bar to get back to the top of a post. Is that normal or just me?

    • pffsfs Hey, that's a pretty good start on that house!  Take a break, tackle this again with fresh eyes.

      The emojis are accessible if you right click in the text bar and "Emoji" is at the top of the menu for me.  That should bring up the emoji menu.  👍

      And yes, if you create a long post there is no way to scroll back up.  It's annoying, but CGCookie only has 1 web dev.  You can report it if you want so they're aware, but it'll probably be a low priority fix.

    • pffsfs good work the house looks good. Keep this up ;) 

  • 11 Dec 2018

    Well… yesterday was a bust. Life stuff got in the way, so I was firefighting most of the day. Started to model an asset for the House Project in an attempt to make it seem “homier”. Spent the better part of today ‘trying’ to finish a garbage can. Oh the trials and tribulations. Learned how to model a wheel again. Got great use of snapping and cutting holes in the model. Rather than do a screenshot, I decided to break up the monotony of the evening and render what I’ve got thus far. Almost finished but for the lid.

    Thanks silentheart00 & yyukinoh1989. The ‘break’ came rather on an involuntary basis, but it worked out in the end. Getting in lots of practice making mistakes. lol.

    Garbage can - first post on YouTube

    • pffsfs Nice looking garbage can from what I can tell.  The one thing that annoys me about the animation is the camera isn't pivoting at the center of the object, so it creates a weird motion in the object.  But hey, one thing at a time, right?  Oh, and another thing (I know I said one thing) is the background/plane.  Kent showed us to use a "top hat" shape for the background past the camera borders to introduce soft gradients from the light in the scene.  It makes the scene look a little more natural and the background is less distracting.  He talked about it in the last class/workshop event and I think in some of his videos, too.  I'll see if I can find a specific video where he references this.  But again, one thing at a time =]

    • pffsfs Found it.  He starts talking about lighting at about 1:30:00.

    • pffsfs really great trash can. Love the animation too. Should do this too. Would be cooler that way :D. You guys for sure keep me so motivated. Can't help but to love you all. I am also curious about what would be comming next :D 

    • pffsfs Nice looking model you got there, and cool to see you've started a polybook! These things seem to have exploded in popularity recently, so I'm looking forward to what else you post here, I'll be keeping an eye on this thread for sure.

  • 13 Dec 2018

    Been missing a couple of days in between, but have been active.

    silentheart00 … appreciate the feedback on the flyby of the garbage can. Guess I was just goofing around. Thank you also for the reference to the lighting live-tut.

    yyukinoh1989 … thank you. Appreciate the kind words. The animation was just to goof off. Unfortunately it caused me to lose any rendering ability and wasted time trying to figure it out. Turns out, it was because of the flyby. I didn’t realize that it changed settings within the render panel. Thanks to ben-reynolds , he got me sorted out.

    Thanks thecabbagedetective . If nothing else it gives me something to look back on andn see the progress being made

    Speaking of progress… got bricks laid outlining the walkways. Getting stupid putting flagstone in the walkway (normally I think this would be done with a ground plane with a texture image) - but no texturing on this, so on and off I putter filling in the walkway. Finally got lamps mounted on the house. Still looking to model lamp posts for the yard too. I find myself running into a lot of snafus along the way, but it’s refreshing to come up with the solutions and know that it won’t (or at least shouldn’t) take nearly as much time to figure out certain problems. I guess it’s all part of learning. I look back at the wasted time spent trying to figure out issues and now realize that the time wasn’t really wasted as long as something is learned from it all.

    Here’s where it stands. It seems like this is taking way too long. Fells like this exercise should have been finished days ago, but I’m also finding myself getting extremely anal with certain stuff. Like this lamp thingy. I went so far as to cut holes in my mesh and then model screw-heads to put in the holes. Ugggg. But, I learned along the way, so not totally a waste.

    Still got dishes to do and off to bed. No more modelling for the Dog today.

    Happy modeling all.

    • pffsfs Yeah, it's certainly getting there!  I understand the pulse to be anal, but sometimes you have to realize what's important and will make the shot and what won't.  I know there's always that nagging feeling in the background of "just in case" but sometimes you have to admit you're done and move on.  You'll figure out at what point you can live with what you've done and move on.

    • silentheart00 pffsfs totally understand the perfectionism aspect, but guess that's part of learning. If you can't see it, don't model it. And learning what you can get away with (for example because it's too far away to see).

      Also agree that even if it's not necessary, it's not time wasted! You've learned something, that's valuable. And problem solving might even be more valuable, a great and useful skill to develop.

      Keep it up, you're doing great 👍🏻

    • pffsfs The lamp looks good. Can't really add much more to what silentheart00 and ssmurfmier1985 have said.

      Keep going and focus on what can be seen and can't be seen. It will feel more natural the more you do it.

  • 6 Apr 2019

    Decided to take the beginners approach to getting through the quirks of 2.80. Yes... I've taken the plunge - downloaded it and immediately switched to "right-select" and "use 2.7x hotkeys". Some things, I guess,  I won't give up on. 

    Right out of the gate, finding certain things is going to be interesting. Took me 5 minutes to find where the preferences were hidden. It does have an interesting look to it - more technical/trendy (just my opinion).

    Delete key is no longer "x", but [shift] + x. Scratching my head over that one, but whatever.

    Went to add some objects to my scene only to not have them show up and thought "AHA!! That's why I'd rather have 2.79". After calming down and looking and looking I noticed that all my objects were getting added to a second "collections" slot (along with the camera and lights).

    Collections... that's when someone comes to collect money you owe. Already I was getting a negative vibe again. Then I noticed I could move my objects out of that infernal "collection" agency and viola... my objects appeared. I can only assume that in having and being able to create multiple "collections", that there will be something useful that comes of it.

    Definitely going to be a lot to wrap my brain around, but I'm through the first lesson and fumbling my way through the changes that are 2.80.


    Where doth the "subdivide" go in the tool bar. Had to use "spacebar" find to get to it. Looked and looked. Am I missing it or is 2.80 missing it.


    Once again, Google is your friend... located in the edge menu [ctrl]+E.

    I'm learning. Just trying desperately to not get frustrated.


    When in face mode select, why on God's green earth did they eliminate the reference dot in the middle of the faces? That is extremely useful when having made the mistake of cancelling an extrude without doubling the [shift]+Z. Bad change. Bad. Still learning :D

    • pffsfs Hey!  Good on you for taking the plunge!  Yes, it's something to get used to, but you got this.  It helps to write down the different shortcut keys into a cheat sheet for future reference.

    • pffsfs Hello Scott, 2.80 takes alot of getting used to; a lot of things are hidden; as for the dot in face select mode, they brought it back, but you'll have to 'activate' it! When in Edit mode, go to the  Overlays drop down menu and under 'Mesh Edit Mode' tick 'Center'.

      Now there is a little dot in the center of the face when in Face Select Mode, but it's only 3 pixels in size. If you want it bigger, you'll have to go to Edit > Preferences > Themes > 3D View > Face Dot Size (near the bottom) and increase that.

      The 'W' key also has Subdivide.

      And I have no clue as to why 'X' doesn't work for you in Object Mode; it works as Delete for me.

      One of the great advantages of Collections is that you can name them (and you can have more than 20).

    • spikeyxxx ... silentheart00 ... I thank you both. I'll have to fool around with collections  a bit. I did mistakenly hide a bunch of objects under a different collection prior to this. Didn't realize it at the time and took 20 minutes trying to find the bloody things.

      So love this community. Thank you again guys

    • pffsfs You're not alone there Scott, that happened to me as well;)

    • pffsfs No problem!  You got this.

  • 15 Apr 2019 (tax day)

    In puttering around, I like the fact the splash page can take you to the type of project you’re working on (i.e. 2D, sculpting, VFX, etc). See... so there’s something I like about 2.80. lol

    Here’s a bit of something that makes no sense: they changed the “object” delete hotkey from “X” to [shift]+X, but they didn’t touch the delete hotkey in edit mode (still “X”)

    *scratches head*

    2.79 use to have layers to move objects to. What is the 2.80 equivalent?

    • pffsfs The 2.8 equivalent of layers is called Collections now.  It's like grouping things in Photoshop; you can toggle visibility and selectability of the collections, too.  Select an Obj, press M to move to a Collection.  You can also nest collections for a large scene and do even more advance stuff I haven't gotten into myself.

  • 22 Apr 2019

    One thing that I am seeing is each time I do that first primitive exercise, it gets much easier each time. Even under the constraints of not using modifiers. Now to get into the habit of modeling “something/anything” each and every day.

    Are we still not able to upload from 2.80 to SketchFab?

    Anyway Exercise 1 for what it’s worth. On to doing some modeling and then moving on through the flow.

    • pffsfs Look at you!  You can teach an old dog new tricks!

      For your Sketchfab upload, the light is cranked really high, which is what Sketchfab seems to default to.  You can fix it by going to your model page->3D Settings at the top right->Lightbulb at the top left->Environment drop down, and I usually tweak the Brightness and Light Intensity (Under Shadows drop down.)  The default lighting settings really blow out the details, so I can't really see anything on your model.  Something to keep in mind for future work.

      Keep going!

    • silentheart00 ... actually this dog has played that trick prior. Just refreshing through 2.8 to see what's changed and get familiar with it (and 3D stuff). And thank you for the light tweaking. Much better now. Off to try appending and/or exporting as you and Miranda suggested. Little by little I'll get the hang of this.


      And here's a copy using ssmurfmier1985 export solution. Yay! So much help, so little time.

    • pffsfs But hey, you're getting faster at the exercise, which is a good indicator you're making progress!  You got this.

  • 23 Apr 2019

    Well damn… going through texturing and UV stuff and if 2.8 didn’t surprise me. When I went to unwrap Suzanne, it automatically marked the seams. Is that a normal thing now? In fact it seams to do that for all of the primitives. Wanted to throw this out there early - Is this part of the new and improved 2.8?

    More to come

  • What the heck happened to the toolbar on the right hand side with 2.8? What a freaking mess they made of it. Someone try to change my mind, please.

    Click Live unwrap in the "options" tab in the toolbar. There aren't ANY tabs any longer on the tool whatever-the-heck they call this.

    I've checked the live unwrap in the UV image editor - not working.

    • pffsfs Hi Scott, I agree with you, that some of the latest UI changes are quite confusing and I am not sure that I like everything, but I guess I'll get used to it..

      So the toolbar on the right is now hidden by default, but there is a tiny arrow on the top right side, which you can click to open it (that is: if you can hit it, I haven't been able to!). Easier is to press N to toggle it.

      Also do this in the UV Editor, maybe you can find some of the 'options' that you are missing; some options have been moved from the left hand toolbar to the right...

      Apparently it's all more consistent now, but as we are so used to where things used to be, we feel a bit lost at times;) But I remember, that in the 'old' Blender, I had to look for some settings and options a long time as well; some things were really well hidden!

      I have never used Live Unwrap, so I'm not sure how it's supposed to act, but it appears to be working. You do need to have everything selected in the 3D View to see the UV's...

      As for your earlier question (from April 23rd), yes, all the primitives have UV's by default in 2.80. This was already an option in 2.79, but now Blender does it automatically, which can actually be a bit annoying at times, for instances when enabling Dynamic Topology, you'll get a warning each time.